summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2015-08-21 13:34:42 +0200
committerGordian Edenhofer2015-08-21 13:34:42 +0200
commit6ec8b00fb2a5385eb99bec4c9e8a30d9215ed62e (patch)
tree14f2f391132f9a6e83aa485121cf06c43d4eb6f8
parent01653b30140b204bd079a030d5d75fca751510d4 (diff)
downloadaur-6ec8b00fb2a5385eb99bec4c9e8a30d9215ed62e.tar.gz
Adding munge-git to conflicts + Indent
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD41
2 files changed, 22 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc0b8e36e3ca..1f27c76198ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,6 +11,7 @@ pkgbase = munge
depends = openssl
optdepends = zlib: zlib compression support
optdepends = bzip2: bzip2 compression support
+ conflicts = munge-git
source = https://github.com/dun/munge/archive/munge-0.5.11.tar.gz
source = arch_munge.init
md5sums = 0b00f0a352f9619f205d41a31a2f3f80
diff --git a/PKGBUILD b/PKGBUILD
index f9d091293480..ff5748993f16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,8 @@ url="https://github.com/dun/munge/wiki"
license=('GPL3' 'LGPL3')
depends=('openssl')
optdepends=("zlib: zlib compression support"
- "bzip2: bzip2 compression support")
+ "bzip2: bzip2 compression support")
+conflicts=('munge-git')
install=$pkgname.install
source=("https://github.com/dun/munge/archive/$pkgname-$pkgver.tar.gz"
"arch_munge.init")
@@ -18,33 +19,33 @@ md5sums=('0b00f0a352f9619f205d41a31a2f3f80'
'668942f323275199d35db5a534d9a80e')
build() {
- cd "$srcdir/$pkgname-$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgname-$pkgver"
- ./configure \
- --prefix=/usr \
- --sbindir=/usr/bin \
- --localstatedir=/var \
- --sysconfdir=/etc
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --localstatedir=/var \
+ --sysconfdir=/etc
- make
+ make
}
package() {
- cd "$srcdir/$pkgname-$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install
- # install arch specific munge init and remove original one...
- rm -f $pkgdir/etc/init.d/munge
- rmdir $pkgdir/etc/init.d
+ # install arch specific munge init and remove original one...
+ rm -f $pkgdir/etc/init.d/munge
+ rmdir $pkgdir/etc/init.d
- install -D -m755 ../arch_munge.init $pkgdir/etc/rc.d/munge
+ install -D -m755 ../arch_munge.init $pkgdir/etc/rc.d/munge
- # /usr/sbin is deprecated in arch, hence using /usr/bin
- sed -i 's/\/usr\/sbin/\/usr\/bin/g' $pkgdir/usr/lib/systemd/system/munge.service
+ # /usr/sbin is deprecated in arch, hence using /usr/bin
+ sed -i 's/\/usr\/sbin/\/usr\/bin/g' $pkgdir/usr/lib/systemd/system/munge.service
- # /var/run/munge will be created in post install, see munge.install
- # because it is bad practice to put package-files in /run
- rmdir $pkgdir/var/run/munge
- rmdir $pkgdir/var/run
+ # /var/run/munge will be created in post install, see munge.install
+ # because it is bad practice to put package-files in /run
+ rmdir $pkgdir/var/run/munge
+ rmdir $pkgdir/var/run
}