summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominik Schwaiger2022-04-25 13:02:50 +0200
committerDominik Schwaiger2022-04-25 13:02:50 +0200
commitf65158298d5e1b44eb3aed0c962c8ad4879acad9 (patch)
treef9830399e4be3b061da2e27ff0b7e23346270ca1
downloadaur-f65158298d5e1b44eb3aed0c962c8ad4879acad9.tar.gz
initial commit (rename snowflake to muon) v1.0.4
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD37
-rwxr-xr-xmuon2
-rw-r--r--muon.desktop7
5 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18357c2aa1b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = muon
+ pkgdesc = Graphical SFTP client and terminal emulator with helpful utilities.
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://github.com/subhra74/snowflake
+ arch = any
+ license = GPL3
+ makedepends = java-environment>=11
+ makedepends = maven
+ depends = java-runtime>=11
+ depends = hicolor-icon-theme
+ depends = bash
+ conflicts = snowflake
+ replaces = snowflake
+ source = muon-1.0.4.tar.gz::https://github.com/subhra74/snowflake/archive/v1.0.4.tar.gz
+ source = muon
+ source = muon.desktop
+ sha256sums = 92b49024a21fb8369476cb77823851f710cc56eaec3fb219330afdac43fab36a
+ sha256sums = b06918fdb24a35e8c3b5348780780dbd40f9665d86e2d84e165add5d753bafc0
+ sha256sums = 00c904959ff8ce0ed19f9f62fe4feaf5e82d80e9bebeae4b9b672e6d681686f4
+
+pkgname = muon
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..35d55b84c7ef
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src
+pkg
+*.tar
+*.tar.xz
+*.tar.gz
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca7ccede246f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Dominik Schwaiger <mail@dominik-schwaiger.ch>
+pkgname='muon'
+oldName='snowflake'
+pkgver=1.0.4
+pkgrel=1
+pkgdesc='Graphical SFTP client and terminal emulator with helpful utilities.'
+arch=('any')
+url="https://github.com/subhra74/snowflake"
+license=('GPL3')
+depends=('java-runtime>=11' 'hicolor-icon-theme' 'bash')
+makedepends=('java-environment>=11' 'maven')
+replaces=('snowflake')
+conflicts=('snowflake')
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/subhra74/snowflake/archive/v${pkgver}.tar.gz"
+ "${pkgname}"
+ "${pkgname}.desktop"
+)
+sha256sums=(
+ '92b49024a21fb8369476cb77823851f710cc56eaec3fb219330afdac43fab36a'
+ 'b06918fdb24a35e8c3b5348780780dbd40f9665d86e2d84e165add5d753bafc0'
+ '00c904959ff8ce0ed19f9f62fe4feaf5e82d80e9bebeae4b9b672e6d681686f4'
+)
+
+build() {
+ cd ${oldName}-${pkgver}
+
+ mvn clean install
+}
+
+package() {
+ install -Dm644 "${oldName}-${pkgver}/target/${oldName}-${pkgver}-full.jar" "${pkgdir}/opt/${pkgname}/${pkgname}.jar"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ install -Dm644 "${oldName}-${pkgver}/src/main/resources/snowflake-logo256.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/Muon.png"
+}
diff --git a/muon b/muon
new file mode 100755
index 000000000000..034011183e7d
--- /dev/null
+++ b/muon
@@ -0,0 +1,2 @@
+#!/bin/sh
+java -jar /opt/muon/muon.jar
diff --git a/muon.desktop b/muon.desktop
new file mode 100644
index 000000000000..a0543d21d97f
--- /dev/null
+++ b/muon.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Muon
+Icon=Muon
+Type=Application
+Exec=muon
+Comment=Graphical SFTP client and terminal emulator with helpful utilities
+Categories=Development;