summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2024-11-27 10:35:42 +0200
committerAdrian Perez de Castro2024-11-27 10:35:42 +0200
commit8e7feb97ea11f1d5ad021e685c32a3c3678de84c (patch)
tree8210f6af2fb00b497be76104a4cfda87efc35b9e
parent7012fd70e3a65b2f2f9d08daff28ce5225d58537 (diff)
downloadaur-8e7feb97ea11f1d5ad021e685c32a3c3678de84c.tar.gz
Bump to version 0.3.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45ce369e82cf..53056be139c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = muon-meson
pkgdesc = meson implementation in C
- pkgver = 0.2.0
+ pkgver = 0.3.1
pkgrel = 1
url = https://muon.build
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = muon-meson
depends = curl
depends = libarchive
provides = muon
- source = https://git.sr.ht/~lattis/muon/archive/0.2.0.tar.gz
- sha256sums = d73db1be5388821179a25a15ba76fd59a8bf7c8709347a4ec2cb91755203f36c
+ source = https://muon.build/releases/v0.3.1/muon-v0.3.1.tar.gz
+ sha256sums = 45f6ad728946a0788188004e3a88a77a7d07b48525ce0646430589d1db4c832e
pkgname = muon-meson
diff --git a/PKGBUILD b/PKGBUILD
index 8ad20c777aaa..3ba5cd8705e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
pkgname=muon-meson
-pkgver=0.2.0
+pkgver=0.3.1
pkgrel=1
pkgdesc="meson implementation in C"
arch=(x86_64)
url="https://muon.build"
license=(GPL3)
-source=("https://git.sr.ht/~lattis/muon/archive/$pkgver.tar.gz")
-sha256sums=('d73db1be5388821179a25a15ba76fd59a8bf7c8709347a4ec2cb91755203f36c')
+source=("$url/releases/v$pkgver/muon-v$pkgver.tar.gz")
+sha256sums=('45f6ad728946a0788188004e3a88a77a7d07b48525ce0646430589d1db4c832e')
depends=(pkgconf curl libarchive)
makedepends=(ninja python-yaml scdoc)
checkdepends=(git)
provides=(muon)
build() {
- cd muon-$pkgver
+ cd "muon-v$pkgver"
rm -rf build*
msg2 "Building stage 1 (bootstrap)"
@@ -35,12 +35,12 @@ build() {
}
check() {
- cd muon-$pkgver/build
+ cd "muon-v$pkgver/build"
./muon test
}
package() {
- cd muon-$pkgver/build
+ cd "muon-v$pkgver/build"
DESTDIR="$pkgdir" ./muon install
# remove this as the `meson` package also provides it