summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2022-04-24 10:26:58 +0100
committerEric Engestrom2022-04-26 12:50:40 +0100
commitf468997bb429130e707256512b765fa6ac167bbe (patch)
tree1f048f76fe2dd3be35d43b7243e6e2ef870de1e1
parentf14c7c842682373acd5a7269fae9769731b9e7e5 (diff)
downloadaur-f468997bb429.tar.gz
use bootstrap script instead of meson to build muon
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cddcbe9e7348..aebdb13bf2e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,11 +6,11 @@ pkgbase = muon-meson-git
arch = x86_64
license = GPL3
makedepends = git
- makedepends = meson
makedepends = scdoc
depends = pkgconf
depends = curl
depends = zlib
+ depends = libarchive
provides = muon
source = git+https://git.sr.ht/~lattis/muon
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 96e3e6a596b0..3179eb0d81be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@ pkgdesc='meson implementation in C'
url='https://sr.ht/~lattis/muon'
license=(GPL3)
arch=(x86_64)
-depends=(pkgconf curl zlib)
-makedepends=(git meson scdoc)
+depends=(pkgconf curl zlib libarchive)
+makedepends=(git scdoc)
conflicts=()
provides=(muon)
source=("git+https://git.sr.ht/~lattis/muon")
@@ -24,11 +24,24 @@ pkgver() {
build() {
cd "$_pkgname"
- meson -D prefix=/usr build
+ rm -rf build
+
+ msg2 "Building stage 1 (bootstrap)"
+ ./bootstrap.sh build-stage1
+
+ msg2 "Building stage 2 (muon from bootstrap)"
+ build-stage1/muon setup build-stage2
+ ninja -C build-stage2
+
+ msg2 "Building stage 3 (muon from muon)"
+ build-stage2/muon setup \
+ -D prefix=/usr \
+ -D meson-docs:prefix=/usr \
+ build
ninja -C build
}
package() {
cd "$_pkgname/build"
- DESTDIR="$pkgdir" meson install
+ DESTDIR="$pkgdir" ./muon install
}