summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsamuel2017-04-10 14:22:32 +1000
committersamuel2017-04-10 14:22:32 +1000
commit10259aeda62053474acaf02330253f528b89822c (patch)
tree2aff9c9d36db2877d876f5b5aea6e316f54a96f9
downloadaur-10259aeda62053474acaf02330253f528b89822c.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b1687963308
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = mup
+ pkgdesc = Mup music typesetting
+ pkgver = 6.5
+ pkgrel = 1
+ arch = x86_64
+ license = GPL
+ makedepends = gcc
+ depends = fltk
+ source = ftp://ftp.arkkra.com/pub/unix/mup65src.tar.gz
+ md5sums = ea79b26a00e0d9ef0924166429aa5a32
+
+pkgname = mup
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18d5901666af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=mup
+pkgver=6.5
+pkgrel=1
+pkgdesc="Mup music typesetting"
+arch=('x86_64')
+url=""
+license=('GPL')
+groups=()
+depends=('fltk')
+makedepends=('gcc')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+#install=
+changelog=
+source=('ftp://ftp.arkkra.com/pub/unix/mup65src.tar.gz')
+noextract=()
+md5sums=('ea79b26a00e0d9ef0924166429aa5a32')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+