summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-06-08 21:41:25 +0200
committerhaawda2017-06-08 21:41:25 +0200
commit8ab7950cd1a9b14d3438614979ecb0963c0aac83 (patch)
treeafdf4cc778c60a22250bc85e1199ecce57a9e5c3
parentc5ef629c276d3b56d4e6bb165260c79917537559 (diff)
downloadaur-8ab7950cd1a9b14d3438614979ecb0963c0aac83.tar.gz
add gcc7.patch and replace some sed commands by makefile.patch
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
-rw-r--r--gcc7.patch12
-rw-r--r--makefile.patch24
4 files changed, 54 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ab0b5990b6a..5e005aa39071 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Thu Jun 8 19:40:32 UTC 2017
pkgbase = mup
pkgdesc = Music publisher, creates PostScript printed music or MIDI
pkgver = 6.5
- pkgrel = 3
+ pkgrel = 4
url = http://arkkra.com
arch = i686
arch = x86_64
@@ -9,8 +11,13 @@ pkgbase = mup
makedepends = gendesk
depends = fltk
depends = libxpm
+ options = !makeflags
source = ftp://ftp.arkkra.com/pub/unix/mup65src.tar.gz
+ source = makefile.patch
+ source = gcc7.patch
sha256sums = b6999b271b6a9ad3bdeabb757e83d5340482b93a7b00513b9ecc5253a62ec7fe
+ sha256sums = d0e2d9d57e4131335678e65c4db94ba182e0fd55c84482acfda630cfceaf5253
+ sha256sums = 0fa766c5907dbe1a026df8cc45c8b8cb75c8238c538d907288d1353e51d0f62b
pkgname = mup
diff --git a/PKGBUILD b/PKGBUILD
index 8b449d487d72..c73fcc96938f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,26 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=mup
pkgver=6.5
-pkgrel=3
+pkgrel=4
pkgdesc="Music publisher, creates PostScript printed music or MIDI"
arch=('i686' 'x86_64')
url="http://arkkra.com"
license=('custom:BSD-like')
depends=('fltk' 'libxpm')
makedepends=('gendesk')
-source=('ftp://ftp.arkkra.com/pub/unix/mup65src.tar.gz')
-sha256sums=('b6999b271b6a9ad3bdeabb757e83d5340482b93a7b00513b9ecc5253a62ec7fe')
+source=('ftp://ftp.arkkra.com/pub/unix/mup65src.tar.gz' 'makefile.patch' 'gcc7.patch')
+sha256sums=('b6999b271b6a9ad3bdeabb757e83d5340482b93a7b00513b9ecc5253a62ec7fe'
+ 'd0e2d9d57e4131335678e65c4db94ba182e0fd55c84482acfda630cfceaf5253'
+ '0fa766c5907dbe1a026df8cc45c8b8cb75c8238c538d907288d1353e51d0f62b')
+options=('!makeflags')
prepare() {
cd $pkgname-$pkgver
- sed -i 's|doc/packages|doc|' makefile
- sed -i 's|pixmaps/mup|pixmaps|' makefile
sed -n '1,40p' mup/mainlist.c > LICENSE
gendesk -f -n --pkgname=mupmate --pkgdesc="Music publisher"
+ patch -p1 < "$srcdir"/makefile.patch || true
+ patch -p1 < "$srcdir"/gcc7.patch || true
}
build() {
diff --git a/gcc7.patch b/gcc7.patch
new file mode 100644
index 000000000000..3d40078c4c11
--- /dev/null
+++ b/gcc7.patch
@@ -0,0 +1,12 @@
+diff -Naur mup-6.5.orig/mupmate/Run.C mup-6.5.new/mupmate/Run.C
+--- mup-6.5.orig/mupmate/Run.C 2017-06-08 20:46:33.410533495 +0200
++++ mup-6.5.new/mupmate/Run.C 2017-06-08 21:15:55.093383589 +0200
+@@ -1192,7 +1192,7 @@
+ }
+ #else
+ command[1] = mup_output;
+- command[2] = '\0';
++ command[2] = "";
+ #endif
+
+ if (execute_command(command,
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..9bffc457af82
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,24 @@
+diff -Naur mup-6.5.orig/makefile mup-6.5.new/makefile
+--- mup-6.5.orig/makefile 2017-06-08 21:38:01.492213651 +0200
++++ mup-6.5.new/makefile 2017-06-08 21:38:23.532091819 +0200
+@@ -53,9 +53,9 @@
+ PREFIX = $(DESTDIR)/usr
+ BINDIR = $(PREFIX)/bin
+ MANDIR = $(PREFIX)/share/man/man1
+-ICONDIR = $(PREFIX)/share/pixmaps/mup
++ICONDIR = $(PREFIX)/share/pixmaps
+ LIBDIR = $(PREFIX)/lib/mup
+-DOCDIR = $(PREFIX)/share/doc/packages/mup
++DOCDIR = $(PREFIX)/share/doc/mup
+
+ # This is the name of your C compiler.
+ # cc would be another common choice.
+@@ -85,7 +85,7 @@
+ # If you installed fltk somewhere other than $(X_LOCATION)/lib
+ # set this to find them, as in
+ # FLTK_LIB_LOCATION = -L/usr/local/lib
+-FLTK_LIB_LOCATION =
++FLTK_LIB_LOCATION = -L/usr/lib
+
+ # The X libraries to link with Mupmate.
+ # Depending on how fltk was compiled, you may be able to omit