summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2016-06-30 04:51:03 -1000
committerGaetan Bisson2016-06-30 04:51:03 -1000
commit79f49d645b49f597ec896732562f29957f4243ca (patch)
treedb56913f88a9b4212c74c21e18e59c5a97fd3e33
parentfe5bbdcf8fab2310361ff9f92cb97343c8774bb1 (diff)
downloadaur-79f49d645b49f597ec896732562f29957f4243ca.tar.gz
use saner makeflags
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8fbd937c0a0..eb595cca11ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mupdf-git
pkgdesc = Lightweight PDF, XPS and CBZ viewer
- pkgver = 20160421.0278606
+ pkgver = 20160630.5da66a0
pkgrel = 1
url = http://mupdf.com/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 8a89195f623b..6dead0db9988 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=mupdf-git
_pkgname=mupdf
-pkgver=20160421.0278606
+pkgver=20160630.5da66a0
pkgrel=1
pkgdesc='Lightweight PDF, XPS and CBZ viewer'
arch=('i686' 'x86_64' 'armv7h')
@@ -28,8 +28,9 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
- git submodule update --init thirdparty/openjpeg
+
git submodule update --init thirdparty/mujs
+ git submodule update --init thirdparty/openjpeg
# needed for zathura-pdf-mupdf
CFLAGS+=' -fPIC'
@@ -42,13 +43,13 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
- make build=release prefix="${pkgdir}"/usr
+ make release XCFLAGS="$CPPFLAGS $CFLAGS" XLIBS="$LDFLAGS"
}
package() {
cd "${srcdir}/${_pkgname}"
- make build=release prefix="${pkgdir}"/usr install
+ make install DESTDIR="${pkgdir}" prefix=/usr
mv "${pkgdir}"/usr/bin/mupdf-x11-curl "${pkgdir}"/usr/bin/mupdf
rm "${pkgdir}"/usr/bin/mupdf-x11