summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2020-05-21 22:42:33 -1000
committerGaetan Bisson2020-05-21 22:42:33 -1000
commit8643099ba7e2c355e161963a3296dd3e90339000 (patch)
tree073020bba96da90709028d42112df82b0218692e
parent5aba2ea936166ad4de6e6f069c68ea93a37a3991 (diff)
downloadaur-8643099ba7e2c355e161963a3296dd3e90339000.tar.gz
use internal freeglut, misc cleanup
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 165f945c1ee0..3cc21a310669 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mupdf-git
pkgdesc = Lightweight PDF, XPS, and E-book viewer
- pkgver = 20191103.2985ec5c0
+ pkgver = 20200521.be1ac3330
pkgrel = 1
url = https://mupdf.com/
arch = i686
@@ -8,8 +8,9 @@ pkgbase = mupdf-git
arch = armv7h
license = AGPL3
makedepends = git
- depends = freeglut
- depends = glu
+ makedepends = libxi
+ makedepends = glu
+ depends = libxrandr
depends = harfbuzz
depends = jbig2dec
depends = libjpeg-turbo
@@ -21,12 +22,14 @@ pkgbase = mupdf-git
conflicts = mupdf-gl
conflicts = mupdf-tools
source = git://git.ghostscript.com/mupdf.git
- source = lcms2::git://git.ghostscript.com/thirdparty-lcms2.git
source = git://git.ghostscript.com/mujs.git
+ source = git://git.ghostscript.com/thirdparty-lcms2.git
+ source = git://git.ghostscript.com/thirdparty-freeglut.git
source = desktop
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 3240d4ebda002cb2c4f42cd42793c6160f1701d349d0acb797819dfd10d4fedd
pkgname = mupdf-git
diff --git a/PKGBUILD b/PKGBUILD
index a601dc485ff2..c4f4bf63c3cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,23 @@
pkgname=mupdf-git
_pkgname=mupdf
-pkgver=20191103.2985ec5c0
+pkgver=20200521.be1ac3330
pkgrel=1
pkgdesc='Lightweight PDF, XPS, and E-book viewer'
arch=('i686' 'x86_64' 'armv7h')
url='https://mupdf.com/'
license=('AGPL3')
-makedepends=('git')
-depends=('freeglut' 'glu' 'harfbuzz' 'jbig2dec' 'libjpeg-turbo' 'openjpeg2')
+makedepends=('git' 'libxi' 'glu')
+depends=('libxrandr' 'harfbuzz' 'jbig2dec' 'libjpeg-turbo' 'openjpeg2')
source=('git://git.ghostscript.com/mupdf.git'
- 'lcms2::git://git.ghostscript.com/thirdparty-lcms2.git'
'git://git.ghostscript.com/mujs.git'
+ 'git://git.ghostscript.com/thirdparty-lcms2.git'
+ 'git://git.ghostscript.com/thirdparty-freeglut.git'
'desktop')
sha256sums=('SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'3240d4ebda002cb2c4f42cd42793c6160f1701d349d0acb797819dfd10d4fedd')
conflicts=("${_pkgname}"{,-gl,-tools})
@@ -32,16 +34,18 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
- sed "/lcms2.git/c url = $(pwd)/../lcms2" -i .gitmodules
+ sed "/freeglut.git/c url = $(pwd)/../thirdparty-freeglut" -i .gitmodules
+ sed "/lcms2.git/c url = $(pwd)/../thirdparty-lcms2" -i .gitmodules
sed "/mujs.git/c url = $(pwd)/../mujs" -i .gitmodules
+ git submodule update --init thirdparty/freeglut
git submodule update --init thirdparty/lcms2
git submodule update --init thirdparty/mujs
# embedding CJK fonts into binaries is madness...
sed '/TOFU_CJK /c #define TOFU_CJK 1/' -i include/mupdf/fitz/config.h
- # fix memento.h confusion
- echo 'THIRD_CFLAGS += -I./include/mupdf' >> Makethird
+ # force internal freeglut; see e.g. 06c999fec01863a90824ba2f9f3ce98ea1a967d3
+ sed 's/USE_SYSTEM_GLUT :=/& no #/g' -i Makethird
}
build() {