summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2021-06-03 18:06:35 +0200
committerGaetan Bisson2021-06-03 18:06:35 +0200
commitac0d290a0f250b1c15be765f93e7b74c6f245d97 (patch)
tree7c85618e6728fce0f88880d3105d1d3cdfc41b6c
parente963e5288a0c3aa71345dad23fb93ded03e9193b (diff)
parent5a11945af35fa41bb04bf770de2f96bb2826b9cc (diff)
downloadaur-ac0d290a0f250b1c15be765f93e7b74c6f245d97.tar.gz
Merge branch 'master' of ssh://aur/mupdf-git
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 25 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d1b3ac4d083..592576e532dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,36 @@
pkgbase = mupdf-git
pkgdesc = Lightweight PDF, XPS, and E-book viewer
pkgver = 20210226.a8f569684
- pkgrel = 1
+ pkgrel = 2
url = https://mupdf.com/
arch = i686
arch = x86_64
arch = armv7h
license = AGPL3
makedepends = git
- depends = freeglut
- depends = glu
+ makedepends = libxi
+ makedepends = glu
+ depends = libxrandr
depends = harfbuzz
depends = jbig2dec
depends = libjpeg-turbo
depends = openjpeg2
+ depends = gumbo-parser
provides = mupdf
+ provides = mupdf-gl
+ provides = mupdf-tools
conflicts = mupdf
+ conflicts = mupdf-gl
+ conflicts = mupdf-tools
source = git://git.ghostscript.com/mupdf.git
- source = lcms2::git://git.ghostscript.com/thirdparty-lcms2.git
source = git://git.ghostscript.com/mujs.git
+ source = git://git.ghostscript.com/thirdparty-lcms2.git
+ source = git://git.ghostscript.com/thirdparty-freeglut.git
source = desktop
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 3240d4ebda002cb2c4f42cd42793c6160f1701d349d0acb797819dfd10d4fedd
pkgname = mupdf-git
diff --git a/PKGBUILD b/PKGBUILD
index d7c5e4d4a01b..7779af8f9276 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,24 +5,26 @@
pkgname=mupdf-git
_pkgname=mupdf
pkgver=20210226.a8f569684
-pkgrel=1
+pkgrel=2
pkgdesc='Lightweight PDF, XPS, and E-book viewer'
arch=('i686' 'x86_64' 'armv7h')
url='https://mupdf.com/'
license=('AGPL3')
-makedepends=('git')
-depends=('freeglut' 'glu' 'harfbuzz' 'jbig2dec' 'libjpeg-turbo' 'openjpeg2')
+makedepends=('git' 'libxi' 'glu')
+depends=('libxrandr' 'harfbuzz' 'jbig2dec' 'libjpeg-turbo' 'openjpeg2' 'gumbo-parser')
source=('git://git.ghostscript.com/mupdf.git'
- 'lcms2::git://git.ghostscript.com/thirdparty-lcms2.git'
'git://git.ghostscript.com/mujs.git'
+ 'git://git.ghostscript.com/thirdparty-lcms2.git'
+ 'git://git.ghostscript.com/thirdparty-freeglut.git'
'desktop')
sha256sums=('SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'3240d4ebda002cb2c4f42cd42793c6160f1701d349d0acb797819dfd10d4fedd')
-conflicts=("${_pkgname}")
-provides=("${_pkgname}")
+conflicts=("${_pkgname}"{,-gl,-tools})
+provides=("${_pkgname}"{,-gl,-tools})
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -32,16 +34,18 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
- sed "/lcms2.git/c url = $(pwd)/../lcms2" -i .gitmodules
+ sed "/freeglut.git/c url = $(pwd)/../thirdparty-freeglut" -i .gitmodules
+ sed "/lcms2.git/c url = $(pwd)/../thirdparty-lcms2" -i .gitmodules
sed "/mujs.git/c url = $(pwd)/../mujs" -i .gitmodules
+ git submodule update --init thirdparty/freeglut
git submodule update --init thirdparty/lcms2
git submodule update --init thirdparty/mujs
# embedding CJK fonts into binaries is madness...
sed '/TOFU_CJK /c #define TOFU_CJK 1/' -i include/mupdf/fitz/config.h
- # fix memento.h confusion
- echo 'THIRD_CFLAGS += -I./include/mupdf' >> Makethird
+ # force internal freeglut; see e.g. 06c999fec01863a90824ba2f9f3ce98ea1a967d3
+ sed 's/USE_SYSTEM_GLUT :=/& no #/g' -i Makethird
}
build() {