summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTugdil Goldhand2017-05-30 19:12:48 +0200
committerTugdil Goldhand2017-05-30 19:12:48 +0200
commit208bfdd14397fca7e554bf8e0c3c648202f452b6 (patch)
tree9f9184385ae010f382e60d23b369ce56a6b325f2
parentf3fd8f69696cbf9507e0248f1863967e048fad2e (diff)
downloadaur-mupdf-nojs.tar.gz
Sync with Arch upstream to 1.11
-rw-r--r--.SRCINFO9
-rw-r--r--0001-mupdf-openjpeg.patch38
-rw-r--r--PKGBUILD13
3 files changed, 33 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63d4f01067ed..6799bfed53d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mupdf-nojs
pkgdesc = Lightweight PDF and XPS viewer
- pkgver = 1.10a
+ pkgver = 1.11
pkgrel = 1
url = http://mupdf.com
arch = i686
@@ -15,18 +15,17 @@ pkgbase = mupdf-nojs
makedepends = libjpeg
makedepends = mesa-libgl
makedepends = openjpeg2
- makedepends = openssl
conflicts = libmupdf
conflicts = mupdf
conflicts = mupdf-gl
conflicts = mupdf-tools
options = staticlibs
- source = http://mupdf.com/downloads/mupdf-1.10a-source.tar.gz
+ source = https://mupdf.com/downloads/mupdf-1.11-source.tar.gz
source = 0001-mupdf-openjpeg.patch
source = mupdf.desktop
source = mupdf.xpm
- sha256sums = aacc1f36b9180f562022ef1ab3439b009369d944364f3cff8a2a898834e3a836
- sha256sums = e55c3b876149d46983b155b0a237fa7d8d47a49e4ecab848bfca3fd549c644c4
+ sha256sums = 209474a80c56a035ce3f4958a63373a96fad75c927c7b1acdc553fc85855f00a
+ sha256sums = 899ca42045806f69919929c2af1921868c053441648524212aa386c7f14bae4f
sha256sums = 70f632e22902ad4224b1d88696702b3ba4eb3c28eb7acf735f06d16e6884a078
sha256sums = a435f44425f5432c074dee745d8fbaeb879038ec1f1ec64f037c74662f09aca8
diff --git a/0001-mupdf-openjpeg.patch b/0001-mupdf-openjpeg.patch
index b41e3477907e..3172ab07783f 100644
--- a/0001-mupdf-openjpeg.patch
+++ b/0001-mupdf-openjpeg.patch
@@ -1,31 +1,35 @@
---- a/source/fitz/load-jpx.c
+diff --git a/source/fitz/load-jpx.c b/source/fitz/load-jpx.c
+index d01de58..6ca3838 100644
+--- a/source/fitz/load-jpx.c
+++ b/source/fitz/load-jpx.c
-@@ -484,13 +484,18 @@
- /* Without the definition of OPJ_STATIC, compilation fails on windows
- * due to the use of __stdcall. We believe it is required on some
- * linux toolchains too. */
-+
+@@ -444,14 +444,18 @@ fz_load_jpx_info(fz_context *ctx, unsigned char *data, size_t size, int *wp, int
+
+ #else /* HAVE_LURATECH */
+
+#ifdef __cplusplus
+extern "C"
+{
#define OPJ_STATIC
- #ifndef _MSC_VER
+ #define OPJ_HAVE_INTTYPES_H
+ #if !defined(_WIN32) && !defined(_WIN64)
#define OPJ_HAVE_STDINT_H
#endif
+#endif
+ #define USE_JPIP
-#include <openjpeg.h>
--
+#include <openjpeg-2.1/openjpeg.h>
-+
- /* OpenJPEG does not provide a safe mechanism to intercept
- * allocations. In the latest version all allocations go
- * though opj_malloc etc, but no context is passed around.
-@@ -972,3 +977,7 @@
+
+ struct fz_jpxd_s
+ {
+@@ -919,6 +923,10 @@ fz_load_jpx_info(fz_context *ctx, unsigned char *data, size_t size, int *wp, int
+ *yresp = state.yres;
}
- #endif /* HAVE_LURATECH */
-+
-+#ifdef __cplusplus
-+}
++#ifdef __cplusplus
++}
+#endif
++
+ #endif /* HAVE_LURATECH */
+
+ #else /* FZ_ENABLE_JPX */
diff --git a/PKGBUILD b/PKGBUILD
index ed349a8436c5..12b653ed8236 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pkgbase=mupdf
pkgbase=${_pkgbase}-nojs
pkgname=(libmupdf-nojs mupdf-nojs mupdf-gl-nojs mupdf-tools-nojs)
-pkgver=1.10a
+pkgver=1.11
pkgrel=1
pkgdesc='Lightweight PDF and XPS viewer'
arch=('i686' 'x86_64')
@@ -17,15 +17,15 @@ url='http://mupdf.com'
license=('AGPL3')
conflicts=(libmupdf mupdf mupdf-gl mupdf-tools)
makedepends=('curl' 'desktop-file-utils' 'freetype2' 'glfw' 'harfbuzz'
- 'jbig2dec' 'libjpeg' 'mesa-libgl' 'openjpeg2' 'openssl')
+ 'jbig2dec' 'libjpeg' 'mesa-libgl' 'openjpeg2')
# we need static libs for zathura-pdf-mupdf
options=('staticlibs')
-source=("http://mupdf.com/downloads/mupdf-${pkgver/_/}-source.tar.gz"
+source=("https://mupdf.com/downloads/mupdf-${pkgver/_/}-source.tar.gz"
'0001-mupdf-openjpeg.patch'
'mupdf.desktop'
'mupdf.xpm')
-sha256sums=('aacc1f36b9180f562022ef1ab3439b009369d944364f3cff8a2a898834e3a836'
-'e55c3b876149d46983b155b0a237fa7d8d47a49e4ecab848bfca3fd549c644c4'
+sha256sums=('209474a80c56a035ce3f4958a63373a96fad75c927c7b1acdc553fc85855f00a'
+'899ca42045806f69919929c2af1921868c053441648524212aa386c7f14bae4f'
'70f632e22902ad4224b1d88696702b3ba4eb3c28eb7acf735f06d16e6884a078'
'a435f44425f5432c074dee745d8fbaeb879038ec1f1ec64f037c74662f09aca8'
)
@@ -41,6 +41,9 @@ prepare() {
# fix includes for jbig2dec
sed '/^JBIG2DEC_CFLAGS :=/s|$| -I./include/mupdf|' -i Makethird
+
+ # this does not build with openssl 1.1.0, so disable checks
+ sed -i 's/pkg-config --exists \(libcrypto\|openssl\)/false/' Makerules
}
build() {