summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrya2015-06-08 23:29:50 +0200
committertrya2015-06-08 23:29:50 +0200
commit5376eb6b900901ad2cd804797146375a4d1dbb49 (patch)
tree3175c9a893da4e0d9cf8300eefbcfb055d83b2d2
downloadaur-5376eb6b900901ad2cd804797146375a4d1dbb49.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5afd21ab03e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mupen64plus-extraplugins
+ pkgdesc = Additional plugins for Mupen64Plus
+ pkgver = 2.0
+ pkgrel = 2
+ url = http://code.google.com/p/mupen64plus
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glew
+ depends = mesa
+ depends = mupen64plus>=2.0
+ options = !strip
+ source = http://mupen64plus.googlecode.com/files/mupen64plus-extraplugins-src-2.0.0.tar.gz
+ md5sums = 7716f17a3988e95ffcec27f0c05810c0
+
+pkgname = mupen64plus-extraplugins
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..091b0005d90b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: trya <tryagainprod@gmail.com>
+
+pkgname=mupen64plus-extraplugins
+pkgver=2.0
+pkgrel=2
+pkgdesc="Additional plugins for Mupen64Plus"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/mupen64plus"
+license=('GPL')
+depends=('glew' 'mesa' "mupen64plus>=$pkgver")
+options=(!strip)
+source=("http://mupen64plus.googlecode.com/files/mupen64plus-extraplugins-src-2.0.0.tar.gz")
+md5sums=('7716f17a3988e95ffcec27f0c05810c0')
+
+prepare() {
+ # patch GLEW headers inclusion
+ cd "$srcdir/mupen64plus-video-z64/src"
+ sed -i rgl.h \
+ -i glshader.cpp \
+ -e 's|#include <glew.h>|#include <GL/glew.h>|'
+}
+
+build() {
+ cd "$srcdir"
+ for _plugdir in mupen64plus-rsp* mupen64plus-video*; do
+ cd $_plugdir
+ make -C projects/unix PREFIX=/usr all
+ cd ..
+ done
+}
+
+package() {
+ cd "$srcdir"
+ for _plugdir in mupen64plus-rsp* mupen64plus-video*; do
+ cd $_plugdir
+ make -C projects/unix PREFIX=/usr DESTDIR="$pkgdir" install
+ cd ..
+ done
+}