summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-04-02 22:41:11 +0000
committerDaniel Bermond2019-04-02 22:41:11 +0000
commit551d636629713cfad8ad07ef08bfc90861aaede3 (patch)
tree1a59d7b17362119f55eb989437f808894c0e988c
parent699e133f2020a346a173bdedd98e625ae91e96e4 (diff)
downloadaur-551d636629713cfad8ad07ef08bfc90861aaede3.tar.gz
Use correct prefix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--mupen64plus-git-core-exe-stack.patch8
3 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1072a0a59f6..fb73fe2f8ff7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mupen64plus-git
pkgdesc = Nintendo64 Emulator (git version)
- pkgver = 2.5.r1032.gef15526e.20181121.044505
+ pkgver = 2.5.9.r8.gb4566a65.20190318.054142
pkgrel = 1
url = https://www.mupen64plus.org/
arch = i686
@@ -40,7 +40,7 @@ pkgbase = mupen64plus-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = d45208a1d9e5a08e6711739c9f52bd88ff016fa5c382a85f305cd4b69dbf62d1
- sha256sums = 859d0a51319e95c4357d539521a0872fedd5de366b759b89d66d663a6da3b6d0
+ sha256sums = a0e0d8cec5bb22e6e5f0e75dde970562bdc7ac94190d66a4cdeea769ac44c77f
sha256sums = e0e6b47aa5ea7b72f2bd5d5ad5e42fee870d947177f2b7e0137b6a93540b894d
pkgname = mupen64plus-git
diff --git a/PKGBUILD b/PKGBUILD
index 9ca8abad51e7..b68bc28cb1b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# mupen64plus component receives a new commit.
pkgname=mupen64plus-git
-pkgver=2.5.r1032.gef15526e.20181121.044505
+pkgver=2.5.9.r8.gb4566a65.20190318.054142
pkgrel=1
pkgdesc='Nintendo64 Emulator (git version)'
arch=('i686' 'x86_64')
@@ -36,7 +36,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'd45208a1d9e5a08e6711739c9f52bd88ff016fa5c382a85f305cd4b69dbf62d1'
- '859d0a51319e95c4357d539521a0872fedd5de366b759b89d66d663a6da3b6d0'
+ 'a0e0d8cec5bb22e6e5f0e75dde970562bdc7ac94190d66a4cdeea769ac44c77f'
'e0e6b47aa5ea7b72f2bd5d5ad5e42fee870d947177f2b7e0137b6a93540b894d')
_m64p_components='core rsp-hle video-rice video-glide64mk2 audio-sdl input-sdl ui-console'
@@ -79,7 +79,7 @@ build() {
do
printf '%s\n' " -> Building component '${_component}'..."
make -C "mupen64plus-${_component}/projects/unix" clean $@
- make -C "mupen64plus-${_component}/projects/unix" all $@
+ make -C "mupen64plus-${_component}/projects/unix" PREFIX='/usr' all $@
done
}
diff --git a/mupen64plus-git-core-exe-stack.patch b/mupen64plus-git-core-exe-stack.patch
index 8d83d90b71d3..33467f1c84d6 100644
--- a/mupen64plus-git-core-exe-stack.patch
+++ b/mupen64plus-git-core-exe-stack.patch
@@ -1,11 +1,11 @@
diff -Naurp a/mupen64plus-core/projects/unix/Makefile b/mupen64plus-core/projects/unix/Makefile
---- a/mupen64plus-core/projects/unix/Makefile 2018-12-31 12:55:18.000000000 +0000
-+++ b/mupen64plus-core/projects/unix/Makefile 2018-12-31 13:08:02.609166199 +0000
-@@ -140,6 +140,7 @@ OPTFLAGS ?= -O3 -flto
+--- a/mupen64plus-core/projects/unix/Makefile 2019-04-02 22:09:22.000000000 +0000
++++ b/mupen64plus-core/projects/unix/Makefile 2019-04-02 22:09:22.000000000 +0000
+@@ -146,6 +146,7 @@ OPTFLAGS ?= -O3 -flto
WARNFLAGS ?= -Wall
CFLAGS += -ffast-math -fno-strict-aliasing -fvisibility=hidden -I../../src -I../../src/asm_defines -DM64P_PARALLEL
CXXFLAGS += -fvisibility-inlines-hidden
+LDFLAGS += -Wl,-z,noexecstack
LDLIBS += -lm
- # Since we are building a shared library, we must compile with -fPIC on some architectures
+ # directory paths