summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-08-15 20:46:36 -0300
committerDaniel Bermond2017-08-15 20:46:36 -0300
commit8d7bb2865ce2bb0e44579b7d4eea5abaab0997bb (patch)
tree37a68d515de27786826356d4f86c5a07b28c1cfa
parenta1a9974fe14a4f1229bff167ce863e7830124a1e (diff)
downloadaur-8d7bb2865ce2bb0e44579b7d4eea5abaab0997bb.tar.gz
Fix build of 'ui-console' component
It needs to be compiled with -fPIC.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9943084e6255..b41e582c115a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Aug 15 23:38:20 UTC 2017
+# Tue Aug 15 23:46:21 UTC 2017
pkgbase = mupen64plus-git
pkgdesc = Nintendo64 Emulator (git version)
- pkgver = 2.5.r374.g1d6d57e.20170529.153246
- pkgrel = 2
+ pkgver = 2.5.r462.ga0672bb.20170813.001839
+ pkgrel = 1
url = http://www.mupen64plus.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 65fbb2cda28d..311d4c91934b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,8 +22,8 @@
# option will force the rebuild of all git sources.
pkgname=mupen64plus-git
-pkgver=2.5.r374.g1d6d57e.20170529.153246
-pkgrel=2
+pkgver=2.5.r462.ga0672bb.20170813.001839
+pkgrel=1
pkgdesc='Nintendo64 Emulator (git version)'
arch=('i686' 'x86_64')
url='http://www.mupen64plus.org/'
@@ -201,6 +201,11 @@ build() {
_previous_version="$_prev_ver_uiconsole"
_current_version="$_curr_ver_uiconsole"
_current_date="$_curr_date_uiconsole"
+
+ # fix for 'ui-console' component (it needs to be compiled with -fPIC)
+ _target_line="$(sed -n '/^ifeq ($(OS), LINUX)/=' "mupen64plus-${_component}/projects/unix/Makefile")"
+ sed -i "$((_target_line + 1))i\ \CFLAGS += -fPIC" "mupen64plus-${_component}/projects/unix/Makefile"
+
;;
*)
printf '%s\n' "error: invalid component '${_component}' (this should not happen!)"