summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-04-22 16:14:22 +0000
committerDaniel Bermond2020-04-22 16:14:22 +0000
commite87b4698fd9f7f76ad344ab9994542b20e6d8169 (patch)
treeffee174bd577a585c7c8b1e25d146b31845acbc2
parent2f2b2e878592da18f6cf62935b9b1aa9d1ac8d92 (diff)
downloadaur-e87b4698fd9f7f76ad344ab9994542b20e6d8169.tar.gz
Remove fix for exe stack (fixed upstream). Remove MANDIR.
MANDIR was dropped by upstream a long time ago[1]. References ---------- [1] https://github.com/mupen64plus/mupen64plus-core/commit/4bd48d31d5d97b88ce2b079558f41b6587f7fc76
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
-rw-r--r--mupen64plus-git-core-exe-stack.patch11
3 files changed, 6 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1ca1da5c522..a52b84e8ddc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = mupen64plus-git
pkgdesc = Nintendo64 Emulator (git version)
- pkgver = 2.5.9.r62.gdbd75133.20200405.081354
+ pkgver = 2.5.9.r70.g4edc53c2.20200422.041041
pkgrel = 1
url = https://www.mupen64plus.org/
- arch = i686
arch = x86_64
license = GPL
makedepends = git
@@ -30,7 +29,6 @@ pkgbase = mupen64plus-git
source = git+https://github.com/mupen64plus/mupen64plus-input-sdl.git
source = git+https://github.com/mupen64plus/mupen64plus-ui-console.git
source = mupen64plus-git-install-fix.patch
- source = mupen64plus-git-core-exe-stack.patch
source = mupen64plus-git-ui-console-pie.patch
sha256sums = SKIP
sha256sums = SKIP
@@ -40,7 +38,6 @@ pkgbase = mupen64plus-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = d45208a1d9e5a08e6711739c9f52bd88ff016fa5c382a85f305cd4b69dbf62d1
- sha256sums = a0e0d8cec5bb22e6e5f0e75dde970562bdc7ac94190d66a4cdeea769ac44c77f
sha256sums = e0e6b47aa5ea7b72f2bd5d5ad5e42fee870d947177f2b7e0137b6a93540b894d
pkgname = mupen64plus-git
diff --git a/PKGBUILD b/PKGBUILD
index c02edf2b4148..a75bfc7e93df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,10 +7,10 @@
# mupen64plus component receives a new commit.
pkgname=mupen64plus-git
-pkgver=2.5.9.r62.gdbd75133.20200405.081354
+pkgver=2.5.9.r70.g4edc53c2.20200422.041041
pkgrel=1
pkgdesc='Nintendo64 Emulator (git version)'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://www.mupen64plus.org/'
license=('GPL')
depends=('speexdsp' 'minizip' 'sdl2' 'glu' 'libsamplerate' 'libpng'
@@ -26,7 +26,6 @@ source=('git+https://github.com/mupen64plus/mupen64plus-core.git'
'git+https://github.com/mupen64plus/mupen64plus-input-sdl.git'
'git+https://github.com/mupen64plus/mupen64plus-ui-console.git'
'mupen64plus-git-install-fix.patch'
- 'mupen64plus-git-core-exe-stack.patch'
'mupen64plus-git-ui-console-pie.patch')
sha256sums=('SKIP'
'SKIP'
@@ -36,7 +35,6 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'd45208a1d9e5a08e6711739c9f52bd88ff016fa5c382a85f305cd4b69dbf62d1'
- 'a0e0d8cec5bb22e6e5f0e75dde970562bdc7ac94190d66a4cdeea769ac44c77f'
'e0e6b47aa5ea7b72f2bd5d5ad5e42fee870d947177f2b7e0137b6a93540b894d')
_m64p_components='core rsp-hle video-rice video-glide64mk2 audio-sdl input-sdl ui-console'
@@ -48,9 +46,6 @@ prepare() {
# remove uneedeed 'source' directory references from install script
patch -Np1 -i mupen64plus-git-install-fix.patch
- # remove executable stack from core library
- patch -Np1 -i mupen64plus-git-core-exe-stack.patch
-
# enable PIE for ui-console interface
patch -Np1 -i mupen64plus-git-ui-console-pie.patch
}
@@ -74,18 +69,17 @@ pkgver() {
build() {
local _component
-
for _component in $_m64p_components
do
printf '%s\n' " -> Building component '${_component}'..."
- make -C "mupen64plus-${_component}/projects/unix" clean $@
- make -C "mupen64plus-${_component}/projects/unix" PREFIX='/usr' all $@
+ make -C "mupen64plus-${_component}/projects/unix" clean
+ make -C "mupen64plus-${_component}/projects/unix" PREFIX='/usr' all
done
}
package() {
# set LDCONFIG since we are using fakeroot and scripts run root commands by checking the uid
- ./m64p_install.sh DESTDIR="$pkgdir" PREFIX='/usr' MANDIR='/usr/share/man' LDCONFIG='true'
+ ./m64p_install.sh DESTDIR="$pkgdir" PREFIX='/usr' LDCONFIG='true'
local _sover
_sover="$(find mupen64plus-core/projects/unix -type f -name 'libmupen64plus.so.*.*' | sed 's/^.*\.so\.//')"
diff --git a/mupen64plus-git-core-exe-stack.patch b/mupen64plus-git-core-exe-stack.patch
deleted file mode 100644
index 33467f1c84d6..000000000000
--- a/mupen64plus-git-core-exe-stack.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Naurp a/mupen64plus-core/projects/unix/Makefile b/mupen64plus-core/projects/unix/Makefile
---- a/mupen64plus-core/projects/unix/Makefile 2019-04-02 22:09:22.000000000 +0000
-+++ b/mupen64plus-core/projects/unix/Makefile 2019-04-02 22:09:22.000000000 +0000
-@@ -146,6 +146,7 @@ OPTFLAGS ?= -O3 -flto
- WARNFLAGS ?= -Wall
- CFLAGS += -ffast-math -fno-strict-aliasing -fvisibility=hidden -I../../src -I../../src/asm_defines -DM64P_PARALLEL
- CXXFLAGS += -fvisibility-inlines-hidden
-+LDFLAGS += -Wl,-z,noexecstack
- LDLIBS += -lm
-
- # directory paths