summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-12-31 13:33:07 +0000
committerDaniel Bermond2018-12-31 13:36:53 +0000
commit05ccb162153e5ee51020181b730fa8f9fa6b7d4c (patch)
tree77707e953ce1887ce6724cffb12a5f0dc8b112b2
parent5a0bfc40b0d186df6f3c21924400907ff5b1f0a4 (diff)
downloadaur-05ccb162153e5ee51020181b730fa8f9fa6b7d4c.tar.gz
Do not rename the source clone. Rename icon. Switch zlib to p7zip.
Upstream now uses only 7za binary for compressed files support[1]. [1] https://github.com/m64p/mupen64plus-gui/commit/3bf730a473bef77f7b6c64586a1fc2eb064243eb
-rw-r--r--PKGBUILD32
-rw-r--r--mupen64plus-gui.desktop2
2 files changed, 17 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e0e435ebf8f..ac3fb8473a70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,37 @@
-# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Maintainer : Daniel Bermond < gmail-com: danielbermond >
pkgname=mupen64plus-gui-git
-pkgver=r162.8077d7d
+_srcname=mupen64plus-gui
+pkgver=r164.3bf730a
pkgrel=1
pkgdesc='Mupen64Plus Graphical User Interface written in Qt5 (git version)'
arch=('i686' 'x86_64')
url='https://github.com/m64p/mupen64plus-gui/'
license=('GPL3')
-depends=('gcc-libs' 'qt5-base' 'sdl2' 'zlib')
+depends=('gcc-libs' 'qt5-base' 'sdl2' 'p7zip')
makedepends=('git')
provides=('mupen64plus-gui')
conflicts=('mupen64plus-gui')
-source=("$pkgname"::'git+https://github.com/m64p/mupen64plus-gui.git'
+source=('git+https://github.com/m64p/mupen64plus-gui.git'
'mupen64plus-gui.desktop')
sha256sums=('SKIP'
- '10aef6fadef59a92cbfd754ee6164b4c34cef43a4de230ef119757f7ea03eeb2')
+ '701550049301d06472fc25f72d8d0599d6d350762e84012f87b113ee68e905de')
+
+prepare() {
+ cd "$_srcname"
+
+ mkdir -p build
+}
pkgver() {
- cd "$pkgname"
+ cd "$_srcname"
# git, no tags available
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$pkgname"
-
- mkdir -p build
- cd build
+ cd "${_srcname}/build"
qmake-qt5 ../mupen64plus-gui.pro
@@ -35,16 +39,12 @@ build() {
}
package() {
- cd "${pkgname}/build"
-
# binary
- install -D -m755 mupen64plus-gui -t "${pkgdir}/usr/bin"
+ install -D -m755 "${_srcname}/build/mupen64plus-gui" -t "${pkgdir}/usr/bin"
# icon
- cd "${srcdir}/${pkgname}"
- install -D -m644 mupen64plus.ico -t "${pkgdir}/usr/share/pixmaps"
+ install -D -m644 "${_srcname}/mupen64plus.ico" "${pkgdir}/usr/share/pixmaps/mupen64plus-gui.ico"
# desktop file
- cd "$srcdir"
install -D -m644 mupen64plus-gui.desktop -t "${pkgdir}/usr/share/applications"
}
diff --git a/mupen64plus-gui.desktop b/mupen64plus-gui.desktop
index 1a4a44f21a42..f0a1a3507e22 100644
--- a/mupen64plus-gui.desktop
+++ b/mupen64plus-gui.desktop
@@ -5,7 +5,7 @@ Name=mupen64plus-gui
Comment=Graphical User Interface for Mupen64Plus
Path=/usr/bin
Exec=mupen64plus-gui
-Icon=mupen64plus
+Icon=mupen64plus-gui
Terminal=false
StartupNotify=false
Categories=Game;