summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMastergatto2021-06-09 23:37:57 +0200
committerMastergatto2021-06-09 23:37:57 +0200
commit32e89f3feae01ea957ecf294bb7e309940ba8034 (patch)
treeed5303e74a42154b36a6c2017d1b156a359b8ba5
downloadaur-32e89f3feae01ea957ecf294bb7e309940ba8034.tar.gz
First release
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD48
-rw-r--r--fix-build.patch11
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..250d8ab3c069
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = mupen64plus-video-parallel-git
+ pkgdesc = Parallel RDP is a Vulkan-based RDP LLE plugin for mupen64plus
+ pkgver = r17.3a85ca6
+ pkgrel = 1
+ url = https://github.com/loganmc10/parallel-rdp-standalone
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = git
+ makedepends = mesa
+ depends = mupen64plus-git
+ optdepends = mupen64plus-rsp-parallel: preferred LLE RSP to be paired with this plugin
+ optdepends = mupen64plus-rsp-cxd4: alternative LLE RSP to be paired with this plugin
+ provides = mupen64plus-video-parallel
+ conflicts = mupen64plus-video-parallel
+ source = git+https://github.com/loganmc10/parallel-rdp-standalone.git
+ source = fix-build.patch
+ sha256sums = SKIP
+ sha256sums = 98ecfc3377f8985606ea6a3c6d82823b4b122aabccc9dbe7ddf1dbcae7aeb673
+
+pkgname = mupen64plus-video-parallel-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8de90429a6f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Snowstorm64
+
+pkgname=mupen64plus-video-parallel-git
+pkgver=r17.3a85ca6
+pkgrel=1
+pkgdesc="Parallel RDP is a Vulkan-based RDP LLE plugin for mupen64plus"
+arch=("x86_64" "i686")
+url="https://github.com/loganmc10/parallel-rdp-standalone"
+license=("MIT")
+depends=("mupen64plus-git")
+makedepends=("git" "mesa")
+optdepends=("mupen64plus-rsp-parallel: preferred LLE RSP to be paired with this plugin"
+ "mupen64plus-rsp-cxd4: alternative LLE RSP to be paired with this plugin")
+provides=(mupen64plus-video-parallel)
+conflicts=(mupen64plus-video-parallel)
+source=("git+https://github.com/loganmc10/parallel-rdp-standalone.git"
+ "fix-build.patch")
+sha256sums=("SKIP"
+ "98ecfc3377f8985606ea6a3c6d82823b4b122aabccc9dbe7ddf1dbcae7aeb673")
+_pkgname=mupen64plus-video-parallel
+_pkgdir=parallel-rdp-standalone
+
+pkgver() {
+ cd "${srcdir}/${_pkgdir}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare(){
+ # We need to correct the include directory's path
+ patch -Np1 -i "${srcdir}/fix-build.patch"
+}
+
+build() {
+ mkdir -p "${srcdir}/${_pkgdir}/build"
+ cd "${srcdir}/${_pkgdir}/build"
+ cmake -DCMAKE_BUILD_TYPE=Release ..
+ cmake --build .
+}
+
+package() {
+ # This plugin is licensed under MIT, so we have to install its custom license as required
+ install -Dm 644 "${srcdir}/${_pkgdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -Dm 644 "${srcdir}/${_pkgdir}/build/${_pkgname}.so" "${pkgdir}/usr/lib/mupen64plus/${_pkgname}.so"
+}
diff --git a/fix-build.patch b/fix-build.patch
new file mode 100644
index 000000000000..1e6ba57f88fe
--- /dev/null
+++ b/fix-build.patch
@@ -0,0 +1,11 @@
+diff --git a/parallel-rdp-standalone/CMakeLists.txt b/parallel-rdp-standalone/CMakeLists.txt
+@@ -4,7 +4,7 @@
+ project(parallel-rdp LANGUAGES CXX C)
+
+ set(NAME_PLUGIN_M64P "mupen64plus-video-parallel")
+-include_directories(../mupen64plus-core/src/api)
++include_directories(/usr/include/mupen64plus)
+ add_definitions(-DM64P_PLUGIN_API -DGRANITE_VULKAN_MT)
+
+ # check for INTERPROCEDURAL_OPTIMIZATION support
+