summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStarterX42022-06-07 01:53:59 +0200
committerStarterX42022-06-07 01:53:59 +0200
commit2adcf0c9699cf551709399b1e14f6a767b2f17ee (patch)
treea2a4f0f182018a8fc10e284281925fb78a8d2afe
downloadaur-2adcf0c9699cf551709399b1e14f6a767b2f17ee.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e32590bdf3fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = murse-git
+ pkgdesc = Open Fortress installing and updating tool. A CLI rewrite of the oftoast GUI tool.
+ pkgver = latest
+ pkgrel = 1
+ url = https://git.sr.ht/~welt/murse
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = go
+ optdepends = steam
+ provides = murse
+ provides = oflauncher
+ provides = oflauncher-rei
+ provides = oftoast
+ source = git+https://git.sr.ht/~welt/murse
+ sha256sums = SKIP
+
+pkgname = murse-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc171fcda8ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Dominik Adrian Grzywak <starterx4 at gmail dot com>
+
+pkgname=murse-git
+pkgver=latest
+pkgrel=1
+pkgdesc="Open Fortress installing and updating tool. A CLI rewrite of the oftoast GUI tool."
+arch=(x86_64)
+url="https://git.sr.ht/~welt/murse"
+license=(GPL3)
+provides=('murse' 'oflauncher' 'oflauncher-rei' 'oftoast')
+makedepends=('git' 'go')
+optdepends=("steam")
+source=("git+https://git.sr.ht/~welt/murse")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd murse
+ printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd murse
+ CGO_ENABLED=0 go build -tags netgo -ldflags "-s -w" ./
+ if [ "$(git rev-parse origin/master)" != "$(git rev-parse HEAD)" ]; then \
+ complete-build; \
+ fi
+}
+
+package() {
+ cd murse
+ install -Dm0755 murse -t "${pkgdir}"/usr/bin
+}