summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Psyriccio2016-05-27 14:23:49 +0300
committerDmitry Psyriccio2016-05-27 14:23:49 +0300
commitac896f68dc0c31c8571cb42f4e369f16b78549ad (patch)
tree7c6f8dff9fba0fa50b24f1e9dd22c94bce48792d
parentf8daf6d06730693af9610137ae32f0ed0b914bda (diff)
downloadaur-ac896f68dc0c31c8571cb42f4e369f16b78549ad.tar.gz
updated to 3.0.pre1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD21
2 files changed, 24 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b87548ec595..4ecfde0f9e94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = muse
pkgdesc = A MIDI/Audio sequencer with recording and editing capabilities
- pkgver = 2.2.1
+ pkgver = 3.0.pre1
pkgrel = 1
url = http://muse-sequencer.org/
install = muse.install
@@ -11,15 +11,23 @@ pkgbase = muse
makedepends = doxygen
makedepends = graphviz
makedepends = ladspa
+ makedepends = lv2
makedepends = dssi
- depends = qt4
+ depends = qt5-base
+ depends = qt5-tools
depends = fluidsynth
depends = lash
depends = liblo
- optdepends = dssi: DSSI plugins
- optdepends = ladspa: LADSPA plugins
- source = https://github.com/muse-sequencer/muse/archive/muse_2_2_1.tar.gz
- sha256sums = eab3b1051bc46ebc150af913e47ffaf6ce447889236819f44e74336aa5f71d32
+ depends = gtkmm
+ depends = lib32-gtk2
+ depends = gcc-libs-multilib
+ depends = ladspa
+ depends = lv2
+ depends = dssi
+ optdepends = python2: Python scripting
+ optdepends = python2-pyqt5: Python scripting
+ source = https://github.com/muse-sequencer/muse/archive/muse_3_0_pre1.tar.gz
+ sha256sums = ce04fb02a88129d0fc458086bcf2f6700ad0ad7989715d15bf89da693104c4c2
pkgname = muse
diff --git a/PKGBUILD b/PKGBUILD
index 6c93ef0c833d..96f4c54f89ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
-# Maintainer: Ainola
+# Maintainer: Yan Burdonsky <psyrccio@gmail.com>
+# Contributor: Ainola
# Contributor: speps
# Contributor: Bernardo Barros
-
pkgname=muse
-pkgver=2.2.1
+pkgver=3.0.pre1
pkgrel=1
pkgdesc="A MIDI/Audio sequencer with recording and editing capabilities"
arch=('i686' 'x86_64')
url="http://muse-sequencer.org/"
license=('GPL2')
-depends=('qt4' 'fluidsynth' 'lash' 'liblo')
-makedepends=('cmake' 'doxygen' 'graphviz' 'ladspa' 'dssi')
-optdepends=('dssi: DSSI plugins'
- 'ladspa: LADSPA plugins')
+depends=('qt5-base' 'qt5-tools' 'fluidsynth' 'lash' 'liblo' 'gtkmm' 'lib32-gtk2' 'gcc-libs-multilib' 'ladspa' 'lv2' 'dssi')
+makedepends=('cmake' 'doxygen' 'graphviz' 'ladspa' 'lv2' 'dssi')
+optdepends=('python2: Python scripting' 'python2-pyqt5: Python scripting')
install="${pkgname}.install"
source=("https://github.com/muse-sequencer/muse/archive/muse_${pkgver//./_}.tar.gz")
-sha256sums=('eab3b1051bc46ebc150af913e47ffaf6ce447889236819f44e74336aa5f71d32')
+sha256sums=('ce04fb02a88129d0fc458086bcf2f6700ad0ad7989715d15bf89da693104c4c2')
build() {
- cd "${srcdir}/muse-muse_${pkgver//./_}/muse2"
+ cd "${srcdir}/muse-muse_${pkgver//./_}/muse3"
# build dir
[ -d bld ] || mkdir bld && cd bld
@@ -27,7 +26,7 @@ build() {
-DCMAKE_BUILD_TYPE=release \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4 \
+ -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt5 \
-DCMAKE_ENABLE_VST_VESTIGE=1 \
-DCMAKE_ENABLE_VST_NATIVE=1 \
-DENABLE_PYTHON=1 \
@@ -39,7 +38,7 @@ build() {
}
package() {
- cd "$srcdir/muse-muse_${pkgver//./_}/muse2/bld"
+ cd "$srcdir/muse-muse_${pkgver//./_}/muse3/bld"
make DESTDIR="$pkgdir" install
# .. and oomidi grepmidi bin