summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabrizio del Tin2020-01-19 18:53:40 +0100
committerFabrizio del Tin2020-01-19 18:53:40 +0100
commit75a26c3ed6f31f1d3539f707f2f95b666ee16c15 (patch)
tree2399b5bd4c56225db2d6da36ad779880e3234bd3
parentbd2ffec92220c5a1c4f6933ac3cda89fd50a40c6 (diff)
downloadaur-75a26c3ed6f31f1d3539f707f2f95b666ee16c15.tar.gz
Added pkgver detection and removed "-git" extension from source
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8001f3a08d7..bf73c86a0169 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,12 +19,17 @@ optdepends=(
)
provides=('muse-git')
conflicts=('muse')
-source=("$pkgname"::'git+https://github.com/muse-sequencer/muse.git')
+source=('git+https://github.com/muse-sequencer/muse.git')
# Because the sources are not static, skip Git checksum:
md5sums=('SKIP')
+pkgver() {
+ cd "$srcdir/muse"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/_/./g;s/muse.//g')"
+}
+
build() {
- cd "${srcdir}/muse-git/muse3/"
+ cd "${srcdir}/muse/muse3/"
sed -i 's/PyInt_AsLong/PyLong_AsLong/g' muse/remote/pyapi.cpp
sed -i 's/PyString_AsString/PyBytes_AsString/g' muse/remote/pyapi.cpp
@@ -52,7 +57,7 @@ build() {
}
package() {
- cd "$srcdir/muse-git/muse3/build"
+ cd "$srcdir/muse/muse3/build"
make DESTDIR="$pkgdir" install
# .. and oomidi grepmidi bin