summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabrizio del Tin2019-10-13 13:04:29 +0200
committerFabrizio del Tin2019-10-13 13:17:28 +0200
commit79e14b7ecadfe5d4631a8138afa483e467302930 (patch)
tree96c0566d2716d3ab8b7f0c3600f48e1b653988f3
parentfae9f3ee24c41384397d21dcb474ad09e4cdda59 (diff)
downloadaur-79e14b7ecadfe5d4631a8138afa483e467302930.tar.gz
Improved harfbuzz compatibility
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7477db01f138..b81ddf05e3cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,7 +32,7 @@ build() {
sed -i 's/Py_InitModule( "muse", g_methodDefinitions );/PyModule_Create( \&muse );/' muse/remote/pyapi.cpp
# build dir
- [ -d bld ] || mkdir bld && cd bld
+ [ -d build ] || mkdir build && cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=release \
@@ -45,11 +45,12 @@ build() {
-DENABLE_LASH=1 \
-DENABLE_OSC=1 \
-DENABLE_RTAUDIO=1 ..
+ sed -i -e 's/CXX_INCLUDES = /CXX_INCLUDES = -I\/usr\/include\/harfbuzz/' muse/lv2Gtk2Support/CMakeFiles/lv2_gtk2_support.dir/flags.make
make
}
package() {
- cd "$srcdir/muse-git/muse3/bld"
+ cd "$srcdir/muse-git/muse3/build"
make DESTDIR="$pkgdir" install
# .. and oomidi grepmidi bin