summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Mitchell2022-12-14 19:04:02 +0000
committerBen Mitchell2022-12-14 19:04:02 +0000
commit5b8eea5cdbaaa926aea047590c83127b1cec2baa (patch)
treedc581702f342ecf8ab216f778e39f66de492c946
downloadaur-5b8eea5cdbaaa926aea047590c83127b1cec2baa.tar.gz
1.0.0.392-1
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD26
-rw-r--r--muse-hub-bin.install30
-rw-r--r--muse-hub.desktop9
-rw-r--r--muse-hub.service15
6 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15e0b1d47826
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = muse-hub-bin
+ pkgdesc = Manage MuseScore Libraries.
+ pkgver = 1.0.0.392
+ pkgrel = 1
+ install = muse-hub-bin.install
+ arch = x86_64
+ provides = muse-hub
+ options = !strip
+ options = !emptydirs
+ source = https://pub-c7a32e5b5d834ec9aeef400105452a42.r2.dev/Muse_Hub.deb
+ source = muse-hub.service
+ source = muse-hub.desktop
+ sha512sums = 8c3b145d4350e70d75548ee174331ff6bbf022cfc0dfd338828c62e99a860fed37254c55b75ac10d0e3f4475dd93e79de22a52fb6fdb5ad78d8b86de9f50f836
+ sha512sums = 52282b6cea0564173a20c922b5c71044d807506431f38457e0df419ca0ac6978004076e4e4985befbbe2481c6a49f3a45722970397918088fda63af1cf9c3c73
+ sha512sums = e880ed5b5c7c2f7fa78d9a3f4cb3e438b7dc1321c6e2470644d9f0ff96fe060dd34640ab0da1349d004c65179cd9b89790242a77b09adf03e5178be63d59817d
+
+pkgname = muse-hub-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..34d182b1702f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.deb
+*.tar.zst
+*.sh
+src
+pkg \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cdf45c2c1992
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ben Mitchell (bjosephmitchell@gmail.com)
+pkgname=muse-hub-bin
+pkgver=1.0.0.392
+pkgrel=1
+pkgdesc="Manage MuseScore Libraries."
+arch=('x86_64')
+url=""
+provides=("muse-hub")
+license=()
+groups=()
+depends=()
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source=("https://pub-c7a32e5b5d834ec9aeef400105452a42.r2.dev/Muse_Hub.deb" "muse-hub.service" "muse-hub.desktop")
+sha512sums=(
+ '8c3b145d4350e70d75548ee174331ff6bbf022cfc0dfd338828c62e99a860fed37254c55b75ac10d0e3f4475dd93e79de22a52fb6fdb5ad78d8b86de9f50f836'
+ '52282b6cea0564173a20c922b5c71044d807506431f38457e0df419ca0ac6978004076e4e4985befbbe2481c6a49f3a45722970397918088fda63af1cf9c3c73'
+ 'e880ed5b5c7c2f7fa78d9a3f4cb3e438b7dc1321c6e2470644d9f0ff96fe060dd34640ab0da1349d004c65179cd9b89790242a77b09adf03e5178be63d59817d'
+)
+
+package(){
+ # Extract package data
+ tar -xJ -f data.tar.xz -C "${pkgdir}"
+ install -Dm644 muse-hub.service "${pkgdir}/usr/lib/systemd/system/muse-hub.service"
+ install -Dm644 muse-hub.desktop "${pkgdir}/usr/share/applications/muse-hub.desktop"
+}
diff --git a/muse-hub-bin.install b/muse-hub-bin.install
new file mode 100644
index 000000000000..691904f616b1
--- /dev/null
+++ b/muse-hub-bin.install
@@ -0,0 +1,30 @@
+post_install() {
+ systemctl daemon-reload
+ systemctl enable --now muse-hub.service
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ # Kill the Muse Hub Client application
+ if pgrep -f Muse.Client.Linux; then killall Muse.Client.Linux; fi
+
+ # Disable the Muse Hub Helper Service
+ systemctl --no-reload disable --now muse-hub.service
+}
+
+post_remove() {
+ # Remove all service files if doing a full uninstall
+ if [ $1 = "remove" ]; then
+ rm -rf /srv/muse-hub
+ rm -rf /var/cache/muse-hub
+ rm -rf /tmp/muse-hub
+
+ rm -rf /var/lib/MuseSampler
+ rm -f /usr/lib/libMuseSamplerCoreLib.so
+
+ rm -rf "$HOME/.muse-hub"
+ fi
+}
diff --git a/muse-hub.desktop b/muse-hub.desktop
new file mode 100644
index 000000000000..a23e1dcd7535
--- /dev/null
+++ b/muse-hub.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Muse Hub
+Exec=muse-hub
+Icon=muse-hub
+Terminal=false
+Type=Application
+Categories=GNOME;Application;Network
+StartupNotify=true \ No newline at end of file
diff --git a/muse-hub.service b/muse-hub.service
new file mode 100644
index 000000000000..7e1cef2b3630
--- /dev/null
+++ b/muse-hub.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Muse Hub Helper Service
+After=network.target
+
+StartLimitBurst=3
+StartLimitIntervalSec=20
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/muse-hub-service
+Restart=always
+RestartSec=5
+WorkingDirectory=/opt/muse-hub
+[Install]
+WantedBy=multi-user.target \ No newline at end of file