summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Gwin2018-09-18 17:24:18 +0200
committerMichael Gwin2018-09-18 17:24:18 +0200
commit12ecfe080327317c91c8d52551cad31b2fa4bacd (patch)
treedc1f44f733aa39892e7166f4c830a0c8d4e56e06
downloadaur-12ecfe080327317c91c8d52551cad31b2fa4bacd.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
-rw-r--r--museekd@.service10
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc1941b68bf2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = museekd-git
+ pkgdesc = A replacement for Museek (daemon component).
+ pkgver = r757.7992c04
+ pkgrel = 1
+ url = http://www.museek-plus.org/
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ makedepends = libxml++2.6
+ depends = libevent
+ depends = libxml2
+ optdepends = libogg
+ optdepends = libvorbis
+ source = museekd-git::git+https://github.com/eLvErDe/museek-plus
+ source = museekd@.service
+ md5sums = SKIP
+ md5sums = b63ed659f9a8e3479378c8c1aa381900
+
+pkgname = museekd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69c185c4630b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Michael Gwin <oksijun+arch at gmail dot com>
+# Contributor: Karol "Kenji Takahashi" Woźniak <kenji.sx>
+pkgname=museekd-git
+pkgver=r757.7992c04
+pkgrel=1
+pkgdesc="A replacement for Museek (daemon component)."
+arch=('x86_64')
+url="http://www.museek-plus.org/"
+license=('GPL2')
+depends=('libevent' 'libxml2')
+optdepends=('libogg' 'libvorbis')
+makedepends=('git' 'cmake' 'libxml++2.6')
+source=("$pkgname::git+https://github.com/eLvErDe/museek-plus" 'museekd@.service')
+md5sums=('SKIP' 'b63ed659f9a8e3479378c8c1aa381900')
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ mkdir -p "$pkgname"/build
+ cd "$pkgname"/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DEVERYTHING=0 -DMURMUR=0 -DMUCOUS=0 -DMUSEEKD=1 -DMUSETUP=0 -DMUSCAN=0 -DMUSEEQ=0 -DPYTHON_BINDINGS=1 "$srcdir"/"$pkgname"
+ make VERBOSE=1
+}
+
+package() {
+ cd "$pkgname"/build
+ make DESTDIR="$pkgdir" install
+ install -Dm755 ${srcdir}/museekd@.service ${pkgdir}/usr/lib/systemd/system/museekd@.service
+}
diff --git a/museekd@.service b/museekd@.service
new file mode 100644
index 000000000000..c55b4b90219c
--- /dev/null
+++ b/museekd@.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Museek daemon for %i
+
+[Service]
+User=%i
+Environment=VAR=/home/%i/.museekd/config.xml
+ExecStart=/usr/bin/museekd --config $VAR
+
+[Install]
+WantedBy=multi-user.target