summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHusam Bilal2016-08-09 20:39:09 +0300
committerHusam Bilal2016-08-09 20:39:09 +0300
commitb5bfc8c4650750a15e872fc75a05a27db5ea3799 (patch)
tree3b76af2d41c72d52c4b716315d11a52951a39bff
downloadaur-b5bfc8c4650750a15e872fc75a05a27db5ea3799.tar.gz
Initial
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD45
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f4c746eb799
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = museeks-bin
+ pkgdesc = A lightweight and cross-platform music player.
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = http://museeks.io
+ arch = x86_64
+ arch = i686
+ license = MIT
+ depends = nodejs
+ provides = museeks
+ conflicts = museeks museeks-git
+ source = https://github.com/KeitIG/museeks/releases/download/0.6.0/museeks-linux-x64.zip
+ md5sums = 9552e82aab69503588724fc1c1d33d40
+
+pkgname = museeks-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c68dd0d59df2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Husam Bilal <husam212 AT gmail DOT com>
+
+pkgname="museeks-bin"
+_pkgname="museeks"
+pkgver="0.6.0"
+pkgrel="1"
+pkgdesc="A lightweight and cross-platform music player."
+arch=("x86_64" "i686")
+url="http://museeks.io"
+license=("MIT")
+depends=("gtk2" "cairo" "freetype2" "fontconfig" "gconf" "nss" "alsa-lib")
+makedepends=("gendesk")
+provides=("museeks")
+conflicts=("museeks museeks-git")
+md5sums=("9552e82aab69503588724fc1c1d33d40")
+
+_platform="x64"
+if [ "$CARCH" = "ia32" ]; then
+ _platform="32bit"
+ md5sums=("e3adb0d0819b0a46cc025990ebc3c380")
+fi
+
+source=("https://github.com/KeitIG/museeks/releases/download/${pkgver}/museeks-linux-${_platform}.zip")
+
+prepare() {
+ gendesk -f -n --pkgname "$_pkgname" --pkgdesc "$pkgdesc"
+}
+
+package() {
+ _base_dir="${srcdir}/museeks-linux-${_platform}"
+
+ install -dm755 "${pkgdir}/usr/share/${_pkgname}"
+ install -dm755 "${pkgdir}/usr/bin"
+
+ install -Dm755 "${_base_dir}/museeks" "${pkgdir}/usr/share/${_pkgname}/${_pkgname}"
+ install -Dm644 "${_base_dir}/"{content_shell.pak,icudtl.dat,libffmpeg.so,libnode.so,natives_blob.bin,snapshot_blob.bin,version,LICENSE} "${pkgdir}/usr/share/${_pkgname}/"
+
+ cp -a "${_base_dir}/"{locales,resources} "${pkgdir}/usr/share/${_pkgname}/"
+
+ ln -s "/usr/share/${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+
+ install -Dm644 "${_base_dir}/resources/app/src/images/logos/museeks.png" "${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
+
+ install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}