summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-01-16 08:01:31 +0100
committerGustavo Alvarez2016-01-16 08:01:31 +0100
commit3f8ec8c520f83d18fdc981c4b6dd868a4b8a2ebc (patch)
tree52dece209998c4775d0077674fce2e3b2780cfb0
downloadaur-3f8ec8c520f83d18fdc981c4b6dd868a4b8a2ebc.tar.gz
Initial commit
-rw-r--r--.SRCINFO47
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD92
3 files changed, 143 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9bd6465a37a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,47 @@
+# Generated by mksrcinfo v8
+# Sat Jan 16 07:01:30 UTC 2016
+pkgbase = musepack-tools-svn
+ pkgdesc = Musepack sv8 decoder/encoder tools and libs (SVN Version)
+ pkgver = 481
+ pkgrel = 1
+ url = http://www.musepack.net
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = subversion
+ makedepends = cmake
+ makedepends = glibc
+ source = libcuefile::svn+http://svn.musepack.net/libcuefile/trunk
+ source = libreplaygain::svn+http://svn.musepack.net/libreplaygain
+ source = libmpc::svn+http://svn.musepack.net/libmpc/trunk
+ source = mppenc::svn+http://svn.musepack.net/mppenc/trunk
+ sha1sums = SKIP
+ sha1sums = SKIP
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = musepack-tools-svn
+ pkgdesc = Musepack decoder/encoder tools and libs. (SVN Version)
+ optdepends = libcuefile-svn: for Musepack (MPC) sv8 chapter editor
+ optdepends = libreplaygain-svn: for Musepack (MPC) ReplayGain calculator
+ provides = musepack-tools
+ provides = libmpcdec
+ provides = libmpcdec.so
+ conflicts = musepack-tools
+ conflicts = libmpcdec
+ replaces = libmpcdec
+
+pkgname = libcuefile-svn
+ pkgdesc = Parses so-called cue sheets and handles the parsed data. (SVN Version)
+ depends = glibc
+ provides = libcuefile
+ provides = libcuefile.so
+ conflicts = libcuefile
+
+pkgname = libreplaygain-svn
+ pkgdesc = A library to adjust audio gain. (SVN Version)
+ depends = glibc
+ provides = libreplaygain
+ provides = libreplaygain.so
+ conflicts = libreplaygain
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c11d76f3be23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,92 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgbase=musepack-tools-svn
+pkgname=('musepack-tools-svn'
+ 'libcuefile-svn'
+ 'libreplaygain-svn'
+ )
+pkgver=481
+pkgrel=1
+pkgdesc="Musepack sv8 decoder/encoder tools and libs (SVN Version)"
+arch=('i686' 'x86_64')
+url='http://www.musepack.net'
+license=('LGPL')
+makedepends=('subversion'
+ 'cmake'
+ 'glibc'
+ )
+source=("libcuefile::svn+http://svn.musepack.net/libcuefile/trunk"
+ "libreplaygain::svn+http://svn.musepack.net/libreplaygain"
+ "libmpc::svn+http://svn.musepack.net/libmpc/trunk"
+ "mppenc::svn+http://svn.musepack.net/mppenc/trunk"
+ )
+sha1sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ mkdir -p build-{libcuefile,libreplaygain,libmpc,mppenc}
+}
+
+build() {
+ cd "${srcdir}/build-libcuefile"
+ cmake ../libcuefile \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+
+ cd "${srcdir}/build-libreplaygain"
+ cmake ../libreplaygain \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+
+ cd "${srcdir}/build-libmpc"
+ cmake ../libmpc \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DREPLAY_GAIN_LIBRARY:FILEPATH="${srcdir}"/build-libreplaygain/src/libreplaygain.so \
+ -DCUEFILE_LIBRARY:FILEPATH="${srcdir}"/build-libcuefile/src/libcuefile.so
+ make
+
+ cd "${srcdir}/build-mppenc"
+ cmake ../mppenc \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package_libcuefile-svn() {
+ pkgdesc="Parses so-called cue sheets and handles the parsed data. (SVN Version)"
+ depends=('glibc')
+ provides=('libcuefile' 'libcuefile.so')
+ conflicts=('libcuefile')
+
+ make -C build-libcuefile DESTDIR="${pkgdir}" install
+ for i in $(find libcuefile/include/cuetools -type f); do install -Dm644 "${i}" "${pkgdir}/usr/include/cuetools/${i}"; done
+}
+
+package_libreplaygain-svn() {
+ pkgdesc="A library to adjust audio gain. (SVN Version)"
+ depends=('glibc')
+ provides=('libreplaygain' 'libreplaygain.so')
+ conflicts=('libreplaygain')
+
+ make -C build-libreplaygain DESTDIR="${pkgdir}" install
+ for i in $(find libreplaygain/include/replaygain -type f); do install -Dm644 "${i}" "${pkgdir}/usr/include/replaygain/${i}"; done
+}
+
+package_musepack-tools-svn() {
+ pkgdesc="Musepack decoder/encoder tools and libs. (SVN Version)"
+ provides=('musepack-tools' 'libmpcdec' 'libmpcdec.so')
+ conflicts=('musepack-tools' 'libmpcdec')
+ replaces=('libmpcdec')
+ optdepends=('libcuefile-svn: for Musepack (MPC) sv8 chapter editor'
+ 'libreplaygain-svn: for Musepack (MPC) ReplayGain calculator')
+
+ make -C build-libmpc DESTDIR="${pkgdir}" install
+ for i in $(find libmpc/include/mpc -type f); do install -Dm644 "${i}" "${pkgdir}/usr/include/mpc/${i}"; done
+
+ make -C build-mppenc DESTDIR="${pkgdir}" install
+} \ No newline at end of file