summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroberon20072015-12-04 10:38:17 +0100
committeroberon20072015-12-04 10:38:17 +0100
commitdf65a2d4352f448e4b7218bf6c1e72d68fbbc54d (patch)
tree5ea7501b48199ffca7dc797e56888a927d416dad
parent51c82e94ab50ef836a120967a7bbcb7b4fa8e149 (diff)
downloadaur-df65a2d4352f448e4b7218bf6c1e72d68fbbc54d.tar.gz
make installable alongside stable build. Include compatability warning
-rw-r--r--.SRCINFO1
-rwxr-xr-xPKGBUILD6
-rwxr-xr-xmusescore.install23
3 files changed, 22 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d92adaefd2d8..d0937213b029 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,7 +22,6 @@ pkgbase = musescore-git
depends = qt5-tools
depends = shared-mime-info
optdepends = lame: MP3 export
- conflicts = musescore
source = git+https://github.com/musescore/MuseScore.git#branch=master
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index bdc2713934f5..d6b570ba6485 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,7 @@ makedepends=('cmake'
'qt5-script'
'texlive-core')
optdepends=('lame: MP3 export')
-conflicts=('musescore')
+conflicts=('')
install='musescore.install'
source=("git+$url.git#branch=$_branch")
@@ -41,12 +41,12 @@ pkgver() {
build() {
cd MuseScore
- make PREFIX='/usr' release
+ make PREFIX='/usr' SUFFIX="-git" LABEL="Git Build" release
}
package() {
cd MuseScore/build.release
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" SUFFIX="-git" LABEL="Git Build" install
}
diff --git a/musescore.install b/musescore.install
index 5474d1623467..41b04576b199 100755
--- a/musescore.install
+++ b/musescore.install
@@ -2,14 +2,29 @@ post_install() {
gtk-update-icon-cache -fqt /usr/share/icons/hicolor
update-desktop-database -q
update-mime-database /usr/share/mime
+
+ msg() {
+ ALL_OFF="\e[1;0m"
+ BOLD="\e[1;1m"
+ GREEN="${BOLD}\e[1;32m"
+ local mesg=$1; shift
+ printf "
+ ${GREEN}==>${ALL_OFF}${BOLD} ${mesg}${ALL_OFF}\n" "$@" >&2
+ }
+
+ msg "This is NOT A STABLE RELEASE!"
+ msg "Scores created with this dev-build may be incompatible with other releases of MuseScore!"
+ msg "You can install this dev-version alongside a stable release"
+ msg "to execute git version use command: 'musescore-git'
+ "
}
post_upgrade() {
- post_install
+ gtk-update-icon-cache -fqt /usr/share/icons/hicolor
+ update-desktop-database -q
+ update-mime-database /usr/share/mime
}
post_remove() {
- post_install
+ post_upgrade
}
-
-# vim: ts=2 sw=2 et: