summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClemmitt Sigler2023-01-26 15:35:40 -0500
committerClemmitt Sigler2023-01-26 15:35:40 -0500
commit2fd5c7fd42af8a8282f5c43b0157dfa7dba723cc (patch)
tree0e5e251735351c1ded8d772f5e4ec714f9773f84
parent2e251a3091706647bf4c473fc9021c38cc870aa6 (diff)
downloadaur-2fd5c7fd42af8a8282f5c43b0157dfa7dba723cc.tar.gz
Pkg updated to install in parallel with musescore4
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD52
-rw-r--r--icons-cpp.patch11
-rw-r--r--logindialog-ui.patch11
-rw-r--r--mscore3-desktop.patch16
-rw-r--r--musescore-cpp.patch11
-rw-r--r--newwizard-cpp.patch11
-rw-r--r--org-musescore-MuseScore3-appdata-xml.patch22
8 files changed, 143 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45f388f6e43e..5c4306e20d2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = musescore3
pkgdesc = Create, play and print beautiful sheet music -- Version 3; End-of-life
pkgver = 3.6.2
- pkgrel = 1
+ pkgrel = 2
url = https://musescore.org/
arch = x86_64
groups = pro-audio
@@ -28,9 +28,20 @@ pkgbase = musescore3
depends = qt5-xmlpatterns
depends = zlib
optdepends = lame: MP3 export
- provides = musescore
- conflicts = musescore
+ provides = musescore=3.6.2
source = git+https://github.com/musescore/MuseScore.git#tag=3224f342d12f4af8ea782e929c49f5ce85f97da6
+ source = icons-cpp.patch
+ source = logindialog-ui.patch
+ source = musescore-cpp.patch
+ source = newwizard-cpp.patch
+ source = mscore3-desktop.patch
+ source = org-musescore-MuseScore3-appdata-xml.patch
sha256sums = SKIP
+ sha256sums = 4dbd0a685b2efc76ff9ec62dc08744ef706aeddeb3202e8a3ef1c10ef6745bbb
+ sha256sums = 4e2b0a0cf88b96403e1403bb3c03eb679aaa9bd8af898d48da911dbb38237e64
+ sha256sums = 032070fcd9725bc10fb056bbe6bf4cd88aeedc1a30fadaadf67a0e137cbefff1
+ sha256sums = 614f0be56acbc1039b9ce1b37922ebf476b953c632538de7dd94e28fbce95cd2
+ sha256sums = 699f1ad0eb8dcc4979e1b88101ed9c4c7cea38a61a2a1b3ca21681b40db82a0b
+ sha256sums = 1d4f34815968e8efd28bef961a72871c617348c256b07be050a1d7f1b91b8307
pkgname = musescore3
diff --git a/PKGBUILD b/PKGBUILD
index 0fa286f3fe5b..d00a6e1ca384 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=musescore3
pkgver=3.6.2
-pkgrel=1
+pkgrel=2
pkgdesc='Create, play and print beautiful sheet music -- Version 3; End-of-life'
arch=(x86_64)
url=https://musescore.org/
@@ -38,15 +38,31 @@ makedepends=(
texlive-core
)
optdepends=('lame: MP3 export')
-conflicts=('musescore')
-provides=('musescore')
+provides=('musescore=3.6.2')
_tag=3224f342d12f4af8ea782e929c49f5ce85f97da6
-source=(git+https://github.com/musescore/MuseScore.git#tag=${_tag})
-sha256sums=(SKIP)
+source=("git+https://github.com/musescore/MuseScore.git#tag=${_tag}"
+ 'icons-cpp.patch'
+ 'logindialog-ui.patch'
+ 'musescore-cpp.patch'
+ 'newwizard-cpp.patch'
+ 'mscore3-desktop.patch'
+ 'org-musescore-MuseScore3-appdata-xml.patch')
+sha256sums=(SKIP
+ '4dbd0a685b2efc76ff9ec62dc08744ef706aeddeb3202e8a3ef1c10ef6745bbb'
+ '4e2b0a0cf88b96403e1403bb3c03eb679aaa9bd8af898d48da911dbb38237e64'
+ '032070fcd9725bc10fb056bbe6bf4cd88aeedc1a30fadaadf67a0e137cbefff1'
+ '614f0be56acbc1039b9ce1b37922ebf476b953c632538de7dd94e28fbce95cd2'
+ '699f1ad0eb8dcc4979e1b88101ed9c4c7cea38a61a2a1b3ca21681b40db82a0b'
+ '1d4f34815968e8efd28bef961a72871c617348c256b07be050a1d7f1b91b8307')
prepare() {
cd MuseScore
git cherry-pick -n 63d8b7ee90e9ec6604e334a3ebb12fced7fab36d
+ # Adapt mscore/musescore to eliminate conflicts with ver. 4
+ patch -Np1 -i "${srcdir}/icons-cpp.patch"
+ patch -Np1 -i "${srcdir}/logindialog-ui.patch"
+ patch -Np1 -i "${srcdir}/musescore-cpp.patch"
+ patch -Np1 -i "${srcdir}/newwizard-cpp.patch"
}
pkgver() {
@@ -75,7 +91,33 @@ build() {
}
package() {
+ # Adapt mscore/musescore to eliminate conflicts with ver. 4
+ patch -Np0 -i "${srcdir}/mscore3-desktop.patch"
+ patch -Np0 -i "${srcdir}/org-musescore-MuseScore3-appdata-xml.patch"
+ #
make DESTDIR="${pkgdir}" install -C build
+ #
+ mv -f "${pkgdir}/usr/bin/mscore" "${pkgdir}/usr/bin/mscore3"
+ rm -f "${pkgdir}/usr/bin/musescore"
+ ln -s mscore3 "${pkgdir}/usr/bin/musescore3"
+ #
+ mv -f "${pkgdir}/usr/share/applications/mscore.desktop" "${pkgdir}/usr/share/applications/mscore3.desktop"
+ #
+ mv -f "${pkgdir}/usr/share/man/man1/mscore.1.gz" "${pkgdir}/usr/share/man/man1/mscore3.1.gz"
+ rm -f "${pkgdir}/usr/share/man/man1/musescore.1.gz"
+ ln -s mscore3.1.gz "${pkgdir}/usr/share/man/man1/musescore3.1.gz"
+ #
+ for icondir in 16x16 24x24 32x32 48x48 64x64 96x96 128x128 512x512; do
+ mv -f "${pkgdir}/usr/share/icons/hicolor/${icondir}/apps/mscore.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${icondir}/apps/mscore3.png"
+ done
+ mv -f "${pkgdir}/usr/share/icons/hicolor/scalable/apps/mscore.svg" \
+ "${pkgdir}/usr/share/icons/hicolor/scalable/apps/mscore3.svg"
+ #
+ mv -f "${pkgdir}/usr/share/metainfo/org.musescore.MuseScore.appdata.xml" \
+ "${pkgdir}/usr/share/metainfo/org.musescore.MuseScore3.appdata.xml"
+ mv -f "${pkgdir}/usr/share/mime/packages/musescore.xml" \
+ "${pkgdir}/usr/share/mime/packages/musescore3.xml"
}
# vim: ts=2 sw=2 et:
diff --git a/icons-cpp.patch b/icons-cpp.patch
new file mode 100644
index 000000000000..71463f7d6305
--- /dev/null
+++ b/icons-cpp.patch
@@ -0,0 +1,11 @@
+--- MuseScore/mscore/icons.cpp.orig 2023-01-25 17:44:15.416019781 -0500
++++ MuseScore/mscore/icons.cpp 2023-01-26 10:27:47.047146152 -0500
+@@ -90,7 +90,7 @@
+ "document-save.svg",
+ "document-save-as.svg",
+ "document-save-online.svg",
+- "mscore.png",
++ "mscore3.png",
+ "acciaccatura.svg",
+ "appoggiatura.svg",
+ "grace4.svg",
diff --git a/logindialog-ui.patch b/logindialog-ui.patch
new file mode 100644
index 000000000000..21dfc7693055
--- /dev/null
+++ b/logindialog-ui.patch
@@ -0,0 +1,11 @@
+--- MuseScore/mscore/cloud/logindialog.ui.orig 2023-01-25 17:44:15.049351628 -0500
++++ MuseScore/mscore/cloud/logindialog.ui 2023-01-25 23:21:08.815768090 -0500
+@@ -37,7 +37,7 @@
+ <string/>
+ </property>
+ <property name="pixmap">
+- <pixmap resource="musescore.qrc">:/data/mscore.png</pixmap>
++ <pixmap resource="musescore.qrc">:/data/mscore3.png</pixmap>
+ </property>
+ <property name="alignment">
+ <set>Qt::AlignCenter</set>
diff --git a/mscore3-desktop.patch b/mscore3-desktop.patch
new file mode 100644
index 000000000000..5ccefeba2008
--- /dev/null
+++ b/mscore3-desktop.patch
@@ -0,0 +1,16 @@
+--- build/mscore.desktop.orig 2022-12-30 06:16:24.000000000 -0500
++++ build/mscore.desktop 2023-01-25 10:23:39.719812761 -0500
+@@ -7,10 +7,10 @@
+ Comment=Create, play and print sheet music
+ Comment[ru]=Визуальный редактор нотных партитур
+ Comment[fr]=Gravure de partitions musicales
+-Exec=mscore %F
+-Icon=mscore
++Exec=mscore3 %F
++Icon=mscore3
+ StartupNotify=true
+-StartupWMClass=mscore
++StartupWMClass=mscore3
+ Terminal=false
+ Type=Application
+ Categories=Qt;Audio;Sequencer;Midi;AudioVideoEditing;Music;AudioVideo;
diff --git a/musescore-cpp.patch b/musescore-cpp.patch
new file mode 100644
index 000000000000..63311b870d6c
--- /dev/null
+++ b/musescore-cpp.patch
@@ -0,0 +1,11 @@
+--- MuseScore/mscore/musescore.cpp.orig 2023-01-25 17:44:15.502686799 -0500
++++ MuseScore/mscore/musescore.cpp 2023-01-26 10:30:50.690698710 -0500
+@@ -1996,7 +1996,7 @@
+ if (enableExperimental) {
+ cornerLabel = new QLabel(this);
+ cornerLabel->setScaledContents(true);
+- cornerLabel->setPixmap(QPixmap(":/data/mscore.png"));
++ cornerLabel->setPixmap(QPixmap(":/data/mscore3.png"));
+ cornerLabel->setGeometry(width() - 48, 0, 48, 48);
+ }
+ #if defined(WIN_SPARKLE_ENABLED)
diff --git a/newwizard-cpp.patch b/newwizard-cpp.patch
new file mode 100644
index 000000000000..2ccf72ef12c3
--- /dev/null
+++ b/newwizard-cpp.patch
@@ -0,0 +1,11 @@
+--- MuseScore/mscore/newwizard.cpp.orig 2023-01-25 17:44:15.506020146 -0500
++++ MuseScore/mscore/newwizard.cpp 2023-01-26 10:33:56.381172478 -0500
+@@ -435,7 +435,7 @@
+ #endif
+ setWizardStyle(wizardStyleValue);
+
+- setPixmap(QWizard::LogoPixmap, QPixmap(":/data/mscore.png"));
++ setPixmap(QWizard::LogoPixmap, QPixmap(":/data/mscore3.png"));
+ setPixmap(QWizard::WatermarkPixmap, QPixmap());
+ setWindowTitle(tr("New Score Wizard"));
+
diff --git a/org-musescore-MuseScore3-appdata-xml.patch b/org-musescore-MuseScore3-appdata-xml.patch
new file mode 100644
index 000000000000..e4e6c4952332
--- /dev/null
+++ b/org-musescore-MuseScore3-appdata-xml.patch
@@ -0,0 +1,22 @@
+--- build/org.musescore.MuseScore.appdata.xml.orig 2022-12-30 06:16:24.000000000 -0500
++++ build/org.musescore.MuseScore.appdata.xml 2023-01-25 14:58:28.761008082 -0500
+@@ -1,7 +1,7 @@
+ <?xml version="1.0" encoding="UTF-8"?>
+ <!-- Copyright 2018 Werner Schweer and others -->
+ <component type="desktop-application">
+- <id>org.musescore.MuseScore</id>
++ <id>org.musescore.MuseScore3</id>
+ <translation type="qt">mscore</translation>
+ <name>MuseScore</name>
+ <summary>Create, playback, and print sheet music for free</summary>
+@@ -403,8 +403,8 @@
+ <release date="2017-05-02" version="2.1.0"/>
+ </releases>
+ <provides>
+- <id>mscore.desktop</id>
++ <id>mscore3.desktop</id>
+ </provides>
+- <launchable type="desktop-id">mscore.desktop</launchable>
++ <launchable type="desktop-id">mscore3.desktop</launchable>
+ <update_contact>jurf_AT_riseup.net</update_contact>
+ </component>