summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDct Mei2019-09-13 15:08:29 +0900
committerDct Mei2019-09-13 15:08:29 +0900
commit25a00b0a70e208fd6c401727eaced58c9d8560ea (patch)
tree6c6464580d8f4e6152cdc685e0a4e18b68af6180
parentbeb84bacb0e098ff81b8ac8750b796b8bcd56d29 (diff)
downloadaur-25a00b0a70e208fd6c401727eaced58c9d8560ea.tar.gz
v3.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85249d2651e1..20d63ae2da32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = music-dl
- pkgdesc = Music-dl is a command line tool which helps you search and download music from multiple sources
- pkgver = 2.2.1
+ pkgdesc = A command line tool which helps you search and download music from multiple sources
+ pkgver = 3.0.0
pkgrel = 1
url = https://github.com/0xHJK/music-dl
arch = any
@@ -9,8 +9,8 @@ pkgbase = music-dl
depends = python-requests
depends = python-pycryptodome
depends = python-prettytable
- source = music-dl-2.2.1.tar.gz::https://github.com/0xHJK/music-dl/archive/v2.2.1.tar.gz
- sha512sums = 74a8c31b341d9da7d997138f743c383fb7b5994dc340dcd4b8ff5d319b8e86f74fcb796a611be316eaa8f62bad26dd0e553dcf003c8ffd288ebd270f697546eb
+ source = music-dl-3.0.0.tar.gz::https://github.com/0xHJK/music-dl/archive/v3.0.0.tar.gz
+ sha512sums = 2fc420bc8a2931a97191ebce18fbb5fc490d399f46bc02f153203283dc1ae4b1da11c624cc33c69fd3ac4fd7a7b0c24ee75fdde04b6cbdb9e5930b43c14c3098
pkgname = music-dl
diff --git a/PKGBUILD b/PKGBUILD
index 4d7d701bfe2d..ff2b4fc3589a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Dct Mei <dctxmei@gmail.com>
pkgname=music-dl
-pkgver=2.2.1
+pkgver=3.0.0
pkgrel=1
-pkgdesc="Music-dl is a command line tool which helps you search and download music from multiple sources"
+pkgdesc="A command line tool which helps you search and download music from multiple sources"
arch=('any')
url="https://github.com/0xHJK/music-dl"
license=('MIT')
depends=("python-click" "python-requests" "python-pycryptodome" "python-prettytable")
source=("$pkgname-$pkgver.tar.gz::https://github.com/0xHJK/music-dl/archive/v$pkgver.tar.gz")
-sha512sums=("74a8c31b341d9da7d997138f743c383fb7b5994dc340dcd4b8ff5d319b8e86f74fcb796a611be316eaa8f62bad26dd0e553dcf003c8ffd288ebd270f697546eb")
+sha512sums=("2fc420bc8a2931a97191ebce18fbb5fc490d399f46bc02f153203283dc1ae4b1da11c624cc33c69fd3ac4fd7a7b0c24ee75fdde04b6cbdb9e5930b43c14c3098")
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -19,5 +19,8 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ rm "$pkgdir/usr/LICENSE"
+ rm "$pkgdir/usr/README.en.md"
install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 644 README.en.md "$pkgdir/usr/share/$pkgname/README"
}