summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-19 08:02:45 +0800
committerzxp198210052024-03-19 08:02:45 +0800
commitf02ba15c280a5aea43d3d01fc02ce871b3b3fff0 (patch)
treed63937758472ef60648a21b64307af3aec006fa3
parentac29735e34326ddc622b7c23907ba5084735af35 (diff)
downloadaur-f02ba15c280a5aea43d3d01fc02ce871b3b3fff0.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--music-you.sh5
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5969a9253478..1f61ccfd5892 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = music-you-bin
pkgdesc = 一个美观简约的Material Design 3 (Material You) 风格网易云音乐播放器pc客户端
pkgver = 3.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://music-you-next.vercel.app
arch = x86_64
license = AGPL-3.0-only
@@ -11,6 +11,6 @@ pkgbase = music-you-bin
source = music-you-3.0.0.deb::https://github.com/GuMengYu/music-you/releases/download/v3.0.0/music-you_3.0.0_amd64.deb
source = music-you.sh
sha256sums = 4cef5119c2c1aa50e2268cbdc9bc3f515fad722546e89ad0e4fa466861c61a35
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = music-you-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1dca73d784f0..32650cc8ff60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=music-you-bin
pkgver=3.0.0
_electronversion=27
-pkgrel=1
+pkgrel=2
pkgdesc="一个美观简约的Material Design 3 (Material You) 风格网易云音乐播放器pc客户端"
arch=('x86_64')
url="https://music-you-next.vercel.app"
@@ -18,11 +18,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('4cef5119c2c1aa50e2268cbdc9bc3f515fad722546e89ad0e4fa466861c61a35'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
sed "s|/opt/${pkgname%-bin}/${pkgname%-bin}|${pkgname%-bin}|g;s|Audio;Music|AudioVideo|g" \
diff --git a/music-you.sh b/music-you.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/music-you.sh
+++ b/music-you.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file