summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun2020-12-20 12:59:35 +0800
committeryjun2020-12-20 12:59:35 +0800
commitf9002c3d37697022a688f29a0ad776a5e9cec8f6 (patch)
tree3f6f71c4a289e54b73d970278cc3b5d9c0432ae4
downloadaur-f9002c3d37697022a688f29a0ad776a5e9cec8f6.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c76903e87d0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = musicfox
+ pkgdesc = netease cloud music terminal client written in Dart.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/AlanAlbert/musicfox
+ arch = x86_64
+ license = MIT
+ makedepends = dart
+ depends = mpg123
+ depends = libnotify
+ provides = musicfox-bin
+ conflicts = musicfox-bin
+ options = !strip
+ source = musicfox-1.2.0.tar.gz::https://github.com/AlanAlbert/musicfox/archive/1.2.0.tar.gz
+ sha256sums = be84b4db8841f9b03e86a70b9000c7a1fa8db417641e460f6d810b0959bc0fd5
+
+pkgname = musicfox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..642f6331a5b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: yjun <jerrysteve1101@gmail.com>
+
+pkgname=musicfox
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="netease cloud music terminal client written in Dart."
+arch=('x86_64')
+url="https://github.com/AlanAlbert/musicfox"
+license=('MIT')
+depends=('mpg123'
+ 'libnotify')
+makedepends=('dart')
+provides=("${pkgname}-bin")
+conflicts=("${pkgname}-bin")
+options=('!strip')
+source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/AlanAlbert/musicfox/archive/${pkgver}.tar.gz")
+sha256sums=('be84b4db8841f9b03e86a70b9000c7a1fa8db417641e460f6d810b0959bc0fd5')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+
+ dart pub get
+}
+
+build() {
+ mkdir -p build
+
+ dart compile exe -o build/${pkgname} ${pkgname}-${pkgver}/bin/main.dart
+}
+
+package() {
+ install -Dm755 build/${pkgname} -t ${pkgdir}/usr/bin
+ install -Dm644 ${pkgname}-${pkgver}/LICENSE -t ${pkgdir}/usr/share/licenses/${pkgname}
+}
+
+# vim: set sw=2 ts=2 et: