summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-02-22 16:49:16 -0700
committerMark Wagie2024-02-22 16:49:16 -0700
commit1ebcfc25265c273bf04f7e42a154b5de468bfd66 (patch)
treea9e646006da07d82643b8668f46cc5cec60652dd
parentf633ae605d57b6afbb09b118010964f891a4e191 (diff)
downloadaur-1ebcfc25265c273bf04f7e42a154b5de468bfd66.tar.gz
add ARM64 support
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cf09937670b..6430048ca21b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,6 +4,7 @@ pkgbase = musicpod-git
pkgrel = 1
url = https://github.com/ubuntu-flutter-community/musicpod
arch = x86_64
+ arch = aarch64
license = GPL-3.0-or-later
checkdepends = appstream-glib
makedepends = chrpath
diff --git a/PKGBUILD b/PKGBUILD
index 4a7b71dbf7f6..111268fad212 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgver=1.0.2.r3.g0fdc2b5
pkgrel=1
_flutter_ver=3.19.0
pkgdesc="Music, radio, television and podcast player"
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://github.com/ubuntu-flutter-community/musicpod"
license=('GPL-3.0-or-later')
depends=('gstreamer' 'gtk3' 'mpv')
@@ -40,9 +40,16 @@ check() {
package() {
cd "${pkgname%-git}"
- install -Dm755 "build/linux/x64/release/bundle/${pkgname%-git}" -t \
+
+ if [ $CARCH == "aarch64" ]; then
+ FLUTTER_ARCH=arm64
+ else
+ FLUTTER_ARCH=x64
+ fi
+
+ install -Dm755 "build/linux/${FLUTTER_ARCH}/release/bundle/${pkgname%-git}" -t \
"$pkgdir/opt/${pkgname%-git}/"
- cp -r build/linux/x64/release/bundle/{data,lib} "$pkgdir/opt/${pkgname%-git}"
+ cp -r build/linux/${FLUTTER_ARCH}/release/bundle/{data,lib} "$pkgdir/opt/${pkgname%-git}"
for i in 64 128; do
install -Dm644 "flatpak/icon${i}.png" \