summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-12-27 09:58:33 -0700
committerMark Wagie2023-12-27 09:58:33 -0700
commit5f37b1a119950bfb07c4ee8610ece0b2eb329e6d (patch)
tree2de0f687fcc4f6c5362f667d7d3fe642af610db9
parent7cc63e31bf168048c5cb897743ed22eae4e4c7c5 (diff)
downloadaur-5f37b1a119950bfb07c4ee8610ece0b2eb329e6d.tar.gz
add check function
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2841dc5b1cb1..5334f013e856 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,7 @@ pkgbase = musicpod-git
url = https://github.com/ubuntu-flutter-community/musicpod
arch = x86_64
license = GPL3
+ checkdepends = appstream-glib
makedepends = clang
makedepends = cmake
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 2edbb0622582..28f7a072cd04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,6 +10,7 @@ url="https://github.com/ubuntu-flutter-community/musicpod"
license=('GPL3')
depends=('gstreamer' 'gtk3' 'mpv')
makedepends=('clang' 'cmake' 'git' 'ninja')
+checkdepends=('appstream-glib')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://github.com/ubuntu-flutter-community/musicpod.git'
@@ -30,6 +31,12 @@ build() {
flutter build linux
}
+check() {
+ cd "${pkgname%-git}"
+ appstream-util validate-relax --nonet "flatpak/${_app_id}.appdata.xml"
+ desktop-file-validate "flatpak/${_app_id}.desktop"
+}
+
package() {
cd "${pkgname%-git}"
install -Dm755 "build/linux/x64/release/bundle/${pkgname%-git}" -t \