summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-21 09:23:14 -0700
committerMark Wagie2024-01-21 09:23:14 -0700
commita113bc554afd093f1c35d5eee87f208434f0bfbb (patch)
tree31c9749579242f7eac060034edc721991c5f578b
parent5f37b1a119950bfb07c4ee8610ece0b2eb329e6d (diff)
downloadaur-a113bc554afd093f1c35d5eee87f208434f0bfbb.tar.gz
Update Flutter ...
- Remove insecure RUNPATH pointing to build dir - Use SPDX license identifier
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5334f013e856..f4c5a793493b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = musicpod-git
pkgdesc = Music, radio, television and podcast player
- pkgver = r741.cbe57c7
+ pkgver = r802.e051973
pkgrel = 1
url = https://github.com/ubuntu-flutter-community/musicpod
arch = x86_64
- license = GPL3
+ license = GPL-3.0-or-later
checkdepends = appstream-glib
+ makedepends = chrpath
makedepends = clang
makedepends = cmake
makedepends = git
@@ -16,8 +17,8 @@ pkgbase = musicpod-git
provides = musicpod
conflicts = musicpod
source = git+https://github.com/ubuntu-flutter-community/musicpod.git
- source = flutter-3.16.5.tar.xz::https://storage.googleapis.com/flutter_infra_release/releases/stable/linux/flutter_linux_3.16.5-stable.tar.xz
+ source = flutter-3.16.8.tar.xz::https://storage.googleapis.com/flutter_infra_release/releases/stable/linux/flutter_linux_3.16.8-stable.tar.xz
sha256sums = SKIP
- sha256sums = 57e59fa3a31be7e87b3847cdf782f1323578bbf70a0cd35f3615f01ab429ac29
+ sha256sums = 7cb12032cf615a92a7bc9042100f3f2af62df7df3ca3bee27f4b153fe218b239
pkgname = musicpod-git
diff --git a/PKGBUILD b/PKGBUILD
index 28f7a072cd04..2fcd575eaf7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=musicpod-git
_app_id=org.feichtmeier.Musicpod
-pkgver=r741.cbe57c7
+pkgver=r802.e051973
pkgrel=1
-_flutter_ver=3.16.5
+_flutter_ver=3.16.8
pkgdesc="Music, radio, television and podcast player"
arch=('x86_64')
url="https://github.com/ubuntu-flutter-community/musicpod"
-license=('GPL3')
+license=('GPL-3.0-or-later')
depends=('gstreamer' 'gtk3' 'mpv')
-makedepends=('clang' 'cmake' 'git' 'ninja')
+makedepends=('chrpath' 'clang' 'cmake' 'git' 'ninja')
checkdepends=('appstream-glib')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://github.com/ubuntu-flutter-community/musicpod.git'
"flutter-${_flutter_ver}.tar.xz::https://storage.googleapis.com/flutter_infra_release/releases/stable/linux/flutter_linux_${_flutter_ver/.hotfix/+hotfix}-stable.tar.xz")
sha256sums=('SKIP'
- '57e59fa3a31be7e87b3847cdf782f1323578bbf70a0cd35f3615f01ab429ac29')
+ '7cb12032cf615a92a7bc9042100f3f2af62df7df3ca3bee27f4b153fe218b239')
pkgver() {
cd "${pkgname%-git}"
@@ -53,4 +53,7 @@ package() {
install -d "$pkgdir/usr/bin"
ln -s "/opt/${pkgname%-git}/${pkgname%-git}" "$pkgdir/usr/bin/"
+
+ # Remove insecure RUNPATH pointing to build dir
+ chrpath --delete "$pkgdir/opt/${pkgname%-git}"/lib/*.so
}