summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-02-16 02:42:57 -0700
committerMark Wagie2021-02-16 02:42:57 -0700
commitb6d02cf5915fb4ec4481ea87bece741683b4b399 (patch)
tree6d23dbc12fd28be9664e3d379fe674108cf20cd2
parent6fc63ec2c345d29948515b108727185461abedc5 (diff)
downloadaur-b6d02cf5915fb4ec4481ea87bece741683b4b399.tar.gz
1.14.3
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore7
-rwxr-xr-xPKGBUILD27
3 files changed, 30 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9dfd958a36a3..7820333c7b51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = musictube
- pkgdesc = YouTube music player
- pkgver = 1.10
+ pkgdesc = YouTube streaming music player
+ pkgver = 1.14.3
pkgrel = 1
url = https://flavio.tordini.org/musictube
arch = x86_64
- license = custom:Proprietary
+ license = custom
depends = qt5-declarative
- depends = phonon-qt5
- depends = hicolor-icon-theme
- source = musictube-1.10.deb::https://flavio.tordini.org/files/musictube/musictube.deb
- sha256sums = 59ccae998e2435ef0fcabbadda50b2c6a710d470bbd886c4ad106b1f722d49b1
+ depends = qt5-x11extras
+ depends = mpv
+ source = musictube-1.14.3.deb::https://flavio.tordini.org/files/musictube/musictube.deb
+ sha256sums = c1edf33158a3848a3b7a477bf8b83bd8da2aba96cf899f46dabdbab42e201659
pkgname = musictube
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 9066533caf82..8fa8600e7d32 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,26 @@
+# Maintainer:
+# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Lex Black <autumn-wind@web.de>
# Contributor: hobi82 <hobi82@gmx.net>
# Contributor: Marius Nestor <marius softpedia com>
-
pkgname=musictube
-pkgver=1.10
+pkgver=1.14.3
pkgrel=1
-pkgdesc="YouTube music player"
+pkgdesc="YouTube streaming music player"
arch=('x86_64')
url="https://flavio.tordini.org/musictube"
-license=('custom:Proprietary')
-depends=('qt5-declarative' 'phonon-qt5' 'hicolor-icon-theme')
-source=("${pkgname}-${pkgver}.deb::https://flavio.tordini.org/files/musictube/musictube.deb")
-sha256sums=('59ccae998e2435ef0fcabbadda50b2c6a710d470bbd886c4ad106b1f722d49b1')
-
+license=('custom')
+depends=('qt5-declarative' 'qt5-x11extras' 'mpv')
+source=("$pkgname-$pkgver.deb::https://flavio.tordini.org/files/$pkgname/$pkgname.deb")
+sha256sums=('c1edf33158a3848a3b7a477bf8b83bd8da2aba96cf899f46dabdbab42e201659')
package() {
- bsdtar -xvf data.tar.xz -C "$pkgdir"
- install -d "$pkgdir"/usr/share/licenses/$pkgname
- ln -s /usr/share/doc/musictube/copyright "$pkgdir"/usr/share/licenses/$pkgname/copyright
+ bsdtar -xvf data.tar.xz -C "$pkgdir"
+
+ # Move license to proper location
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ mv "$pkgdir/usr/share/doc/$pkgname/copyright" "$pkgdir/usr/share/licenses/$pkgname"
+
+ # Remove deprecated app menu
+ rm -rf "$pkgdir/usr/share/menu"
}