summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuís Ferreira2018-09-05 23:09:02 +0100
committerLuís Ferreira2018-09-05 23:09:02 +0100
commit456f14c6075614a3aad354a612d9d0796c7fde7d (patch)
tree92e3126a3d518d9411670a6095cb3b07a473630f
parent9528848b6af60d11a6167bd28bf6da12950f3861 (diff)
downloadaur-456f14c6075614a3aad354a612d9d0796c7fde7d.tar.gz
fix curl command and change filename in order to work
Signed-off-by: Luís Ferreira <contact@lsferreira.net>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bd70643ef48..efbfd7b20279 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = musixmatch-bin
pkgdesc = Lyrics platform where users can search and share lyrics
- pkgver = 0.19.4
+ pkgver = 0.20.20
pkgrel = 1
url = https://www.musixmatch.com/
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = musixmatch-bin
depends = nss
optdepends = spotify: Display the lyrics of the currently playing song
source = eula.html
- sha256sums = cfbc4ad07b1566e0ebf88927349f35f5064ecf71d363027614ec18ec293f8664
+ sha256sums = 988119d55691f5bdc91da81d31f2cc460de9c0d74312f4739f813ded7efdf03c
pkgname = musixmatch-bin
diff --git a/PKGBUILD b/PKGBUILD
index 455190305e70..9b88e4380320 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=musixmatch-bin
_pkgname=musixmatch
-pkgver=0.19.4
+pkgver=0.20.20
pkgrel=1
pkgdesc='Lyrics platform where users can search and share lyrics'
arch=('x86_64')
@@ -15,7 +15,7 @@ sha256sums=('988119d55691f5bdc91da81d31f2cc460de9c0d74312f4739f813ded7efdf03c')
prepare() {
msg2 'Downloading from download-app.musixmatch.com...'
- curl 'https://download-app.musixmatch.com/' -A 'Linux x86_64' -D headers.txt -OJf
+ curl 'https://download-app.musixmatch.com/' -A 'Linux x86_64' -D headers.txt -Lf -o linux_amd64.deb
}
pkgver() {
@@ -24,7 +24,7 @@ pkgver() {
}
package() {
- ar vx "./${_pkgname}_${pkgver}_amd64.deb"
+ ar vx "./linux_amd64.deb"
tar xaf data.tar.xz -C "$pkgdir"
mkdir -p "${pkgdir}/usr/bin"