summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrad Erhart2020-01-27 19:01:00 -0800
committerBrad Erhart2020-01-27 19:01:00 -0800
commitc69263f998468289ef2d19fbd07480d5654a56fa (patch)
tree8dc2d1b423270dbdf38d82559974202f27a2c740
parentbd75e227bff3be96ce68739673c99b003c909f88 (diff)
downloadaur-c69263f998468289ef2d19fbd07480d5654a56fa.tar.gz
Updating Musixmatch to v3.9.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD50
2 files changed, 37 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99d82ce12ec9..f86b5e28975e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = musixmatch-bin
- pkgdesc = Lyrics platform where users can search and share lyrics
- pkgver = 3.6.1
+ pkgdesc = Lyrics for your music
+ pkgver = 3.9.0
pkgrel = 1
- url = https://www.musixmatch.com/
+ url = https://about.musixmatch.com/apps
arch = x86_64
license = custom
+ depends = dconf
depends = desktop-file-utils
- depends = gconf
+ depends = electron
depends = hicolor-icon-theme
depends = libnotify
depends = libxtst
depends = nss
- optdepends = spotify: Display the lyrics of the currently playing song
+ optdepends = spotify: Instant synchronised lyrics
+ source = https://download-app.musixmatch.com/download/musixmatch_3.9.0-linux_x64.deb
source = eula.md
+ sha256sums = 9c348ac4d761c44b284da99bbb6cddfb6fda754f06b8baf992d169cb153e9fa6
sha256sums = 98debf3d134d676f8188406d03b880c0ccde743b882b8d1e0bcaf02dd2eb0705
pkgname = musixmatch-bin
diff --git a/PKGBUILD b/PKGBUILD
index 7ac54288c5c4..cc80e1a00b7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,42 @@
# Maintainer: Brad Erhart <brae.04+aur@gmail.com>
-# Contributor: Adriaan Zonnenberg <amz@adriaan.xyz>
pkgname=musixmatch-bin
-_pkgname=musixmatch
-pkgver=3.6.1
+_pkgname=${pkgname%-bin}
+pkgver=3.9.0
pkgrel=1
-pkgdesc='Lyrics platform where users can search and share lyrics'
+pkgdesc='Lyrics for your music'
arch=('x86_64')
url='https://about.musixmatch.com/apps'
license=('custom')
-depends=('desktop-file-utils' 'gconf' 'hicolor-icon-theme' 'libnotify' 'libxtst' 'nss')
-optdepends=('spotify: Display the lyrics of the currently playing song')
-source=('eula.md')
-sha256sums=('98debf3d134d676f8188406d03b880c0ccde743b882b8d1e0bcaf02dd2eb0705')
+depends=(
+ 'dconf'
+ 'desktop-file-utils'
+ 'electron'
+ 'hicolor-icon-theme'
+ 'libnotify'
+ 'libxtst'
+ 'nss'
+)
+optdepends=('spotify: Instant synchronised lyrics')
+source=(
+ "https://download-app.musixmatch.com/download/${_pkgname}_$pkgver-linux_x64.deb"
+ 'eula.md'
+)
+sha256sums=(
+ '9c348ac4d761c44b284da99bbb6cddfb6fda754f06b8baf992d169cb153e9fa6'
+ '98debf3d134d676f8188406d03b880c0ccde743b882b8d1e0bcaf02dd2eb0705'
+)
prepare() {
- curl 'https://download-app.musixmatch.com/' -A 'Linux x86_64' -D headers.txt -Lf -o linux_amd64.deb
-}
-
-pkgver() {
- # Extract the version from the filename.
- grep -oiP 'content-disposition: attachment; filename=.*musixmatch_\K([0-9.]+)(?=_amd64.deb.*)' headers.txt
+ tar xf data.tar.xz
+ sed -i 's,;x-scheme-handler/mxm,,' usr/share/mime/packages/$_pkgname.xml
+ sed -i 's,/opt/Musixmatch/,,' usr/share/applications/$_pkgname.desktop
+ mkdir -p usr/lib/$_pkgname "$pkgdir"
+ mv opt/Musixmatch/resources/app.asar usr/lib/$_pkgname
}
package() {
- ar vx "./linux_amd64.deb"
- tar xaf data.tar.xz -C "$pkgdir"
-
- mkdir -p "${pkgdir}/usr/bin"
- ln -s /opt/Musixmatch/$_pkgname "$pkgdir/usr/bin/$_pkgname"
-
- install -D -m644 eula.md "$pkgdir/usr/share/licenses/$pkgname/eula.md"
+ mv usr "$pkgdir"
+ install -D eula.md -t "$pkgdir/usr/share/licenses/$_pkgname"
+ echo -e '#!/bin/sh\n\nexec electron /usr/lib/musixmatch/app.asar "$@"' | install -Dm 755 /dev/stdin "$pkgdir/usr/bin/$_pkgname"
}