summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohann CAHIER2020-01-29 18:28:46 +0100
committerJohann CAHIER2020-01-29 18:28:46 +0100
commit9e0448ede6fe6c8637419d0169a69448fbed0316 (patch)
treef9555b1d03380c32ab03d9834ec6fa4797b90651
downloadaur-9e0448ede6fe6c8637419d0169a69448fbed0316.tar.gz
Version 0.99
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9380acf2e383
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mustach
+ pkgver = 0.99
+ pkgrel = 1
+ url = https://gitlab.com/jobol/mustach/
+ arch = x86_64
+ license = Apache-2.0
+ makedepends = gcc
+ makedepends = make
+ makedepends = json-c
+ depends = json-c
+ provides = mustach
+ source = https://gitlab.com/jobol/mustach/-/archive/0.99/mustach-0.99.zip
+ md5sums = c36a37d9e46c7db1225853c7fb207265
+
+pkgname = mustach
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf5ba57970cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Johann CAHIER <johann.cahier@iot.bzh>
+pkgname=mustach
+pkgver=0.99
+pkgrel=1
+description="mustach is a C implementation of the mustache template specification.
+See : http://mustache.github.io/"
+arch=('x86_64')
+url="https://gitlab.com/jobol/mustach/"
+license=('Apache-2.0')
+depends=('json-c')
+makedepends=('gcc' 'make' 'json-c')
+checkdepends=()
+optdepends=()
+provides=('mustach')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://gitlab.com/jobol/mustach/-/archive/0.99/mustach-0.99.zip")
+noextract=()
+md5sums=('c36a37d9e46c7db1225853c7fb207265')
+validpgpkeys=()
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+# install -D -m644 "${srcdir}/${pkgname%-git}/LICENSE-2.0.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-2.0.txt"
+}