summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorltdk2022-01-22 14:26:23 -0500
committerltdk2022-01-22 14:26:23 -0500
commita4d3c33b3863d54e427849487ece56468e207968 (patch)
tree42b5ddd922353b988e0db40c9289e5b083f7c3a4
parentf4433604d674fc25e0d49804616bcac0f81fac16 (diff)
downloadaur-a4d3c33b3863d54e427849487ece56468e207968.tar.gz
Update to 1.1.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da61ac53432c..644c2890bba5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = mustach
- pkgdesc = mustach is a C implementation of the mustache template specification. See : http://mustache.github.io/
- pkgver = 0.99
+ pkgdesc = mustach is a C implementation of the mustache template specification.
+ pkgver = 1.1.0
pkgrel = 1
url = https://gitlab.com/jobol/mustach/
arch = x86_64
- license = Apache-2.0
+ arch = aarch64
+ license = ISC
makedepends = gcc
makedepends = make
- makedepends = json-c
depends = json-c
- provides = mustach
- source = https://gitlab.com/jobol/mustach/-/archive/0.99/mustach-0.99.zip
- md5sums = c36a37d9e46c7db1225853c7fb207265
+ source = https://gitlab.com/jobol/mustach/-/archive/1.1.0/mustach-1.1.0.zip
+ sha256sums = a31ede8351e03ae0c87d9d79fcbe40eef11daf6587f13c583847c5142bb3986e
pkgname = mustach
-
diff --git a/PKGBUILD b/PKGBUILD
index 1e6ceb23e2e5..fe61a44446e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
-# Maintainer: Johann CAHIER <johann.cahier@iot.bzh>
+# Maintainer: Clar Fon <usr@ltdk.xyz>
+# Contributor: Johann CAHIER <johann.cahier@iot.bzh>
pkgname=mustach
-pkgver=0.99
+pkgver=1.1.0
pkgrel=1
-pkgdesc="mustach is a C implementation of the mustache template specification.
-See : http://mustache.github.io/"
-arch=('x86_64')
+pkgdesc="mustach is a C implementation of the mustache template specification."
+arch=('x86_64' 'aarch64')
url="https://gitlab.com/jobol/mustach/"
-license=('Apache-2.0')
+license=('ISC')
depends=('json-c')
-makedepends=('gcc' 'make' 'json-c')
+makedepends=('gcc' 'make')
checkdepends=()
optdepends=()
-provides=('mustach')
+provides=()
conflicts=()
replaces=()
backup=()
options=()
install=
changelog=
-source=("https://gitlab.com/jobol/mustach/-/archive/0.99/mustach-0.99.zip")
+source=("https://gitlab.com/jobol/mustach/-/archive/$pkgver/mustach-$pkgver.zip")
noextract=()
-md5sums=('c36a37d9e46c7db1225853c7fb207265')
+sha256sums=('a31ede8351e03ae0c87d9d79fcbe40eef11daf6587f13c583847c5142bb3986e')
validpgpkeys=()
-
build() {
cd "$srcdir/$pkgname-$pkgver"
make
@@ -31,6 +30,5 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
-# install -D -m644 "${srcdir}/${pkgname%-git}/LICENSE-2.0.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-2.0.txt"
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
}