summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhashworks2020-06-06 19:42:23 +0200
committerhashworks2020-06-06 19:42:23 +0200
commite87ed1444f4e07a3eb5d4319ac9c03ac8d5524de (patch)
tree1721bddd2277a64d11e531fd9a85dd896a9cabd1
parent2669a927ceda8aa0779ab8775fd0244eb2f832c8 (diff)
downloadaur-e87ed1444f4e07a3eb5d4319ac9c03ac8d5524de.tar.gz
PKGBUILD improvements
- $url can be re-used in source=() - non-unique filename in source=() - use install -D -d -m<mode> -o $owner-uid -g $owner-gid ... for creating directories - use install -d -m<mode> ... for copying files
-rwxr-xr-x.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a621cf58b05d..5ee8f4482618 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = mustache
arch = i686
arch = x86_64
license = Boost
- source = https://github.com/kainjow/Mustache/archive/v4.1.tar.gz
+ source = mustache-4.1.tar.gz::https://github.com/kainjow/Mustache/archive/v4.1.tar.gz
sha256sums = acd66359feb4318b421f9574cfc5a511133a77d916d0b13c7caa3783c0bfe167
pkgname = mustache
diff --git a/PKGBUILD b/PKGBUILD
index 7eede19069bb..a2714648e816 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,11 @@ pkgdesc="Mustache implementation for modern C++"
license=('Boost')
arch=('armv7h' 'i686' 'x86_64')
url='https://github.com/kainjow/Mustache'
-source=("https://github.com/kainjow/Mustache/archive/v${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
sha256sums=(acd66359feb4318b421f9574cfc5a511133a77d916d0b13c7caa3783c0bfe167)
package() {
- mkdir -p ${pkgdir}/usr/include/
- cp Mustache-${pkgver}/mustache.hpp ${pkgdir}/usr/include/
- chmod 644 ${pkgdir}/usr/include/mustache.hpp
+ install -D -d -m755 "${pkgdir}/usr/include/"
+ install -m644 "Mustache-${pkgver}/mustache.hpp" "${pkgdir}/usr/include/"
}