summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrexky2019-10-06 14:36:52 +0800
committerrexky2019-10-06 14:36:52 +0800
commit59333eb5e794b2a693bc2dd0b400a1de534bf232 (patch)
tree79fe2732e98de4acdd091c525b97ecd0e327b553
downloadaur-59333eb5e794b2a693bc2dd0b400a1de534bf232.tar.gz
updated PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df6599b25c87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mustream-git
+ pkgdesc = A quick 'hack' to stream any music (from spotify) through the command line.
+ pkgver = r38.f0d6c02
+ pkgrel = 1
+ url = https://github.com/belkadev/mustream
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = spotify
+ depends = bash
+ provides = mustream
+ source = mustream::git+https://github.com/belkadev/mustream.git
+ md5sums = SKIP
+
+pkgname = mustream-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b4a414d8356
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: timescam <rex.ky.ng at gmail dot com>
+
+_pkgname=mustream
+pkgname=$_pkgname-git
+pkgver=r38.f0d6c02
+pkgrel=1
+pkgdesc="A quick 'hack' to stream any music (from spotify) through the command line."
+arch=(any)
+url="https://github.com/belkadev/$_pkgname"
+license=('GPL3')
+makedepends=('git')
+depends=(
+ 'spotify'
+ 'bash'
+)
+provides=("$_pkgname")
+
+source=("$_pkgname::git+https://github.com/belkadev/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package () {
+ install -Dm755 "$srcdir/$_pkgname/mustream.sh" "$pkgdir/usr/bin/play"
+} \ No newline at end of file