summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEray Aydın2015-07-25 07:40:17 +0300
committerEray Aydın2015-07-25 07:40:17 +0300
commit53e171010190bcfa4a4fcbf3a719ebc9d8d4221d (patch)
treec472e2b2eb06e72b02bf901338fc3bb36212e278
downloadaur-53e171010190bcfa4a4fcbf3a719ebc9d8d4221d.tar.gz
Updated to 1.08
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD61
-rw-r--r--etc_confd_mutantfactions11
-rw-r--r--mutantfactions21
-rw-r--r--mutantfactions-16x16.pngbin0 -> 854 bytes
-rw-r--r--mutantfactions-24x24.pngbin0 -> 1491 bytes
-rw-r--r--mutantfactions-32x32.pngbin0 -> 2016 bytes
-rw-r--r--mutantfactions-48x48.pngbin0 -> 3537 bytes
-rw-r--r--mutantfactions-64x64.pngbin0 -> 4399 bytes
-rw-r--r--mutantfactions-server26
-rw-r--r--mutantfactions.desktop8
-rw-r--r--mutantfactions.install27
-rw-r--r--mutantfactions.service12
13 files changed, 208 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5eaa57547f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = mutantfactions
+ pkgdesc = Free multiplayer action game
+ pkgver = 1.08
+ pkgrel = 1
+ url = http://mutantfactions.net
+ install = mutantfactions.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = unionfs-fuse
+ depends = hicolor-icon-theme
+ depends = xdg-utils
+ depends = glu
+ depends = libxrandr
+ depends = freealut
+ conflicts = subvein
+ replaces = subvein
+ source = http://mutantfactions.net/downloads/MutantFactions1080.tar.gz
+ source = mutantfactions
+ source = mutantfactions-server
+ source = mutantfactions.service
+ source = etc_confd_mutantfactions
+ source = mutantfactions-16x16.png
+ source = mutantfactions-24x24.png
+ source = mutantfactions-32x32.png
+ source = mutantfactions-48x48.png
+ source = mutantfactions-64x64.png
+ source = mutantfactions.desktop
+ md5sums = edba55c5c743649c64711ac182388970
+ md5sums = 415352df252c48df74e738735eed903f
+ md5sums = 59164a2e1a8bb8005abcb1529ccd2e5d
+ md5sums = 90647a6ec51f37085ab3a43842925c2b
+ md5sums = b01cfca81170bce397091f05febd8e5e
+ md5sums = 146240abe45b133a5c5ea2c0fdd17b7d
+ md5sums = cac9d34ccd69e207d14e55aa28a0d280
+ md5sums = 64058b1043f76a92e8da3cfad4345f66
+ md5sums = 1a806f08c1d728528bfcb546ba390dba
+ md5sums = 967ba3a3dbf9db02037275ea36b64b19
+ md5sums = 8d30e75e332d85c990de235a1f7827fa
+
+pkgname = mutantfactions
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27e4dde3ac93
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Nuno Araujo <nuno.araujo@russo79.com>
+pkgname=mutantfactions
+pkgver=1.08
+pkgrel=1
+pkgdesc="Free multiplayer action game"
+arch=('i686' 'x86_64')
+url="http://mutantfactions.net"
+license=('custom')
+depends=('unionfs-fuse' 'hicolor-icon-theme' 'xdg-utils')
+if [[ "$CARCH" == "x86_64" ]]; then
+ depends+=('lib32-glu' 'lib32-libxrandr' 'lib32-freealut')
+else
+ depends+=('glu' 'libxrandr' 'freealut')
+fi
+optdepends=()
+conflicts=('subvein')
+replaces=('subvein')
+install=mutantfactions.install
+source=("http://mutantfactions.net/downloads/MutantFactions1080.tar.gz"
+ "mutantfactions"
+ "mutantfactions-server"
+ "mutantfactions.service"
+ "etc_confd_mutantfactions"
+ "mutantfactions-16x16.png"
+ "mutantfactions-24x24.png"
+ "mutantfactions-32x32.png"
+ "mutantfactions-48x48.png"
+ "mutantfactions-64x64.png"
+ "mutantfactions.desktop")
+md5sums=('edba55c5c743649c64711ac182388970'
+ '415352df252c48df74e738735eed903f'
+ '59164a2e1a8bb8005abcb1529ccd2e5d'
+ '90647a6ec51f37085ab3a43842925c2b'
+ 'b01cfca81170bce397091f05febd8e5e'
+ '146240abe45b133a5c5ea2c0fdd17b7d'
+ 'cac9d34ccd69e207d14e55aa28a0d280'
+ '64058b1043f76a92e8da3cfad4345f66'
+ '1a806f08c1d728528bfcb546ba390dba'
+ '967ba3a3dbf9db02037275ea36b64b19'
+ '8d30e75e332d85c990de235a1f7827fa')
+
+package() {
+ mkdir -p $pkgdir/opt/mutantfactions
+ cp -r $srcdir/MutantFactions/. $pkgdir/opt/mutantfactions
+ rm -rf $pkgdir/opt/mutantfactions/lib
+ chmod -R g+w $pkgdir/opt/mutantfactions/data
+
+ install -m 755 -D $srcdir/mutantfactions $pkgdir/usr/bin/mutantfactions
+ install -m 755 -D $srcdir/mutantfactions-server $pkgdir/usr/bin/mutantfactions-server
+ install -m 644 -D $srcdir/mutantfactions.service $pkgdir/usr/lib/systemd/system/mutantfactions.service
+ install -m 644 -D $srcdir/etc_confd_mutantfactions $pkgdir/etc/conf.d/mutantfactions
+ install -m 644 -D $srcdir/mutantfactions-16x16.png $pkgdir/usr/share/icons/hicolor/16x16/apps/mutantfactions.png
+ install -m 644 -D $srcdir/mutantfactions-24x24.png $pkgdir/usr/share/icons/hicolor/24x24/apps/mutantfactions.png
+ install -m 644 -D $srcdir/mutantfactions-32x32.png $pkgdir/usr/share/icons/hicolor/32x32/apps/mutantfactions.png
+ install -m 644 -D $srcdir/mutantfactions-48x48.png $pkgdir/usr/share/icons/hicolor/48x48/apps/mutantfactions.png
+ install -m 644 -D $srcdir/mutantfactions-64x64.png $pkgdir/usr/share/icons/hicolor/64x64/apps/mutantfactions.png
+ install -m 644 -D $srcdir/mutantfactions.desktop $pkgdir/usr/share/applications/mutantfactions.desktop
+ install -m 755 -d $pkgdir/var/lib/mutantfactions
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/etc_confd_mutantfactions b/etc_confd_mutantfactions
new file mode 100644
index 000000000000..d717d4381c07
--- /dev/null
+++ b/etc_confd_mutantfactions
@@ -0,0 +1,11 @@
+#
+# Arguments to be passed to the mutant factions dedicated server
+#
+# Available args
+#
+# -m <max_nb_of_players> : Max number of players
+# -p <port> : Port to listen to
+# -h <username> : Username to whom community credits should be given for
+
+MUTANT_FACTION_ARGS=""
+
diff --git a/mutantfactions b/mutantfactions
new file mode 100644
index 000000000000..0221acca59c2
--- /dev/null
+++ b/mutantfactions
@@ -0,0 +1,21 @@
+#! /bin/sh
+
+cleanup()
+{
+ fusermount -u $HOME/.mutantfactions/overlay
+}
+
+if [[ ! -d $HOME/.mutantfactions/overlay ]]; then
+ mkdir -p $HOME/.mutantfactions/overlay
+fi
+if [[ ! -d $HOME/.mutantfactions/data ]]; then
+ mkdir -p $HOME/.mutantfactions/data
+fi
+
+unionfs -o cow $HOME/.mutantfactions/data=RW:/opt/mutantfactions=RO $HOME/.mutantfactions/overlay
+trap cleanup SIGTERM
+trap cleanup SIGKILL
+trap cleanup SIGINT
+$HOME/.mutantfactions/overlay/MutantFactions $@
+cleanup
+
diff --git a/mutantfactions-16x16.png b/mutantfactions-16x16.png
new file mode 100644
index 000000000000..da214984b187
--- /dev/null
+++ b/mutantfactions-16x16.png
Binary files differ
diff --git a/mutantfactions-24x24.png b/mutantfactions-24x24.png
new file mode 100644
index 000000000000..52c6aaa7e7ff
--- /dev/null
+++ b/mutantfactions-24x24.png
Binary files differ
diff --git a/mutantfactions-32x32.png b/mutantfactions-32x32.png
new file mode 100644
index 000000000000..242a7a48c90f
--- /dev/null
+++ b/mutantfactions-32x32.png
Binary files differ
diff --git a/mutantfactions-48x48.png b/mutantfactions-48x48.png
new file mode 100644
index 000000000000..7828953bff06
--- /dev/null
+++ b/mutantfactions-48x48.png
Binary files differ
diff --git a/mutantfactions-64x64.png b/mutantfactions-64x64.png
new file mode 100644
index 000000000000..72af607f02d5
--- /dev/null
+++ b/mutantfactions-64x64.png
Binary files differ
diff --git a/mutantfactions-server b/mutantfactions-server
new file mode 100644
index 000000000000..b38b02ee9579
--- /dev/null
+++ b/mutantfactions-server
@@ -0,0 +1,26 @@
+#! /bin/sh
+
+source /etc/conf.d/mutantfactions
+
+USER=$(id -un)
+if [[ $USER != "mutantfactions" ]]; then
+ echo "This program should only be run by the mutantfactions user"
+ exit
+fi
+
+cleanup()
+{
+ fusermount -u $HOME/.mutantfactions/overlay
+}
+
+if [[ ! -d $HOME/.mutantfactions/overlay ]]; then
+ mkdir -p $HOME/.mutantfactions/overlay
+fi
+if [[ ! -d $HOME/.mutantfactions/data ]]; then
+ mkdir -p $HOME/.mutantfactions/data
+fi
+
+unionfs -o cow $HOME/.mutantfactions/data=RW:/opt/mutantfactions=RO $HOME/.mutantfactions/overlay
+trap cleanup SIGINT
+$HOME/.mutantfactions/overlay/MutantFactionsServer $MUTANT_FACTIONS_ARGS
+
diff --git a/mutantfactions.desktop b/mutantfactions.desktop
new file mode 100644
index 000000000000..894a66f435ca
--- /dev/null
+++ b/mutantfactions.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Version=1.0
+Name=Mutant Factions
+Type=Application
+Comment=Free multiplayer action game.
+Exec=mutantfactions
+Icon=mutantfactions
+Categories=Game;
diff --git a/mutantfactions.install b/mutantfactions.install
new file mode 100644
index 000000000000..e540e06f30b6
--- /dev/null
+++ b/mutantfactions.install
@@ -0,0 +1,27 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
+ if [ ! `grep mutantfactions /etc/group` ]; then
+ groupadd mutantfactions &> /dev/null;
+ fi
+
+ id mutantfactions &>/dev/null || \
+ useradd -g mutantfactions -d /var/lib/mutantfactions -s /bin/false mutantfactions
+
+ chgrp -R mutantfactions /opt/mutantfactions/data
+ chown mutantfactions:mutantfactions /var/lib/mutantfactions
+ echo " >> Add yourself to the mutantfactions group to run the game."
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ userdel mutantfactions &> /dev/null
+ groupdel mutantfactions &> /dev/null
+}
+
+post_remove () {
+ xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
+}
+
diff --git a/mutantfactions.service b/mutantfactions.service
new file mode 100644
index 000000000000..cdd7cff43271
--- /dev/null
+++ b/mutantfactions.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Dedicated server for mutant factions
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/mutantfactions-server
+Type=simple
+User=mutantfactions
+Group=mutantfactions
+
+[Install]
+WantedBy=multi-user.target