summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormach62018-08-29 19:52:05 -0400
committermach62018-08-29 19:52:05 -0400
commit8ef8da051072a9ad1c8f562ec234a31081c008ba (patch)
treeb8f23c3d787c8b6bf48cb75b6d8be7666a0f1949
parente55db404e3972c8c263fbf382937487673d25627 (diff)
downloadaur-8ef8da051072a9ad1c8f562ec234a31081c008ba.tar.gz
Add symlink for eigen3
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32095ce7a6a1..4acfb6261ba9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,9 +9,8 @@ pkgdesc="MUlticomponent Thermodynamic And Transport properties for partially ION
arch=('i686' 'x86_64')
url="https://sync.vki.ac.be/mpp/mutationpp"
license=('GPL3')
-depends=('eigen' 'gcc-libs')
-checkdepends=('eigen')
-makedepends=('python2' 'git' 'gcc' 'cmake')
+depends=('eigen3' 'gcc-libs')
+makedepends=('git' 'gcc' 'cmake')
source=("$_pkgname::git+https://sync.vki.ac.be/mpp/mutationpp.git")
sha256sums=('SKIP')
export MAKEFLAGS="-j"$(cat /proc/cpuinfo | awk '/^processor/{print $3}' | wc -l)
@@ -76,4 +75,7 @@ Version: ${pkgver}
Libs: -L\${prefix}/lib -lmutation++
Cflags: -I\${prefix}/include/mutation++
EOF
+
+ # add symbolic link for eigen3 header, this is necessary for coolfluid
+ ln -srf ${pkgdir}/usr/include/eigen3 ${pkgdir}/usr/include/mutation++/eigen3
}