summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLoui Chang2016-07-22 21:17:24 -0400
committerLoui Chang2016-07-22 21:18:35 -0400
commit475898465044b5018e53c6c640771376015653ae (patch)
treed9f656ec6eaaddc14d03463e4aac5e6b929dd8fb
parent6b298c5eb60ff8040a8ddb182d6446f4552eae7b (diff)
downloadaur-475898465044b5018e53c6c640771376015653ae.tar.gz
Oh gawd this is horrid. Why would anyone want this? Add --enable-sidebar
Also change tab to space Other minor cleanups/fixes Signed-off-by: Loui Chang <louipc.ist@gmail.com>
-rw-r--r--PKGBUILD62
1 files changed, 33 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c253e32ad381..2e06f1ccc36a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,56 +2,60 @@
_pkgname=mutt
pkgname="${_pkgname}-hg"
-pkgver=r6454.17a4f92e4a95
+pkgver=6742.7b9763564598
pkgrel=1
pkgdesc="A small but very powerful text-based mail client"
url="http://www.mutt.org/"
arch=(i686 x86_64)
license=('GPL')
-depends=('gdbm' 'libidn' 'mime-types' 'zlib' 'gpgme' 'ncurses')
-#depends+=('openssl>=0.9.8e' 'libsasl')
+depends=('gdbm' 'gpgme' 'libidn' 'mime-types' 'ncurses' 'zlib')
+
+# Uncomment if enabling imap, pop, or smtp
+#depends+=('krb5' 'libsasl' 'openssl')
+
makedepends=('mercurial' 'gnupg' 'libxslt')
conflicts=("${_pkgname}")
provides=("${_pkgname}")
-options=('!strip')
-source=('hg+http://dev.mutt.org/hg/mutt#branch=default')
+
+source=("hg+http://dev.mutt.org/hg/mutt#branch=default")
md5sums=(SKIP)
pkgver() {
- cd "$srcdir/${_pkgname}"
- printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+ cd "$srcdir/${_pkgname}"
+ printf "%s.%s" "$(hg identify -n)" "$(hg identify -i)"
}
build() {
- cd ${srcdir}/${_pkgname}
+ cd ${srcdir}/${_pkgname}
# Mutt should be used with external MTAs
# Uncomment relevant build parameters if you want to use the builtin MTA
# Remember to adjust dependencies.
- ./prepare \
- --prefix=/usr \
- --sysconfdir=/etc \
- --enable-debug \
- --enable-hcache \
- --enable-gpgme \
- --enable-pgp \
- --with-idn \
- --with-regex \
-# --enable-imap \
-# --enable-pop \
-# --enable-smtp \
-# --with-sasl \
-# --with-ssl=/usr \
-
-
- make
+ ./prepare \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-debug \
+ --enable-hcache \
+ --enable-gpgme \
+ --enable-pgp \
+ --with-idn \
+ --with-regex \
+# --enable-sidebar \
+# --enable-imap \
+# --enable-pop \
+# --enable-smtp \
+# --with-sasl \
+# --with-ssl=/usr \
+# --with-gss=/usr \
+
+ make
}
package() {
- cd ${srcdir}/${_pkgname}
+ cd "${srcdir}/${_pkgname}"
- make DESTDIR=${pkgdir} install
- rm -f ${pkgdir}/etc/mime.types*
- install -Dm644 contrib/gpg.rc ${pkgdir}/etc/Muttrc.gpg.dist
+ make DESTDIR="${pkgdir}" install
+ rm -f "${pkgdir}/etc/mime.types"*
+ install -Dm644 contrib/gpg.rc "${pkgdir}/etc/Muttrc.gpg.dist"
}