summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWu Zhenyu2023-09-03 17:47:42 +0800
committerWu Zhenyu2023-09-03 17:47:42 +0800
commit5e9be96e2ef644d86a2416a1bf684f0a76e87643 (patch)
tree133f00b64a109747fa70038b2e5123db300ad671
downloadaur-5e9be96e2ef644d86a2416a1bf684f0a76e87643.tar.gz
:tada: Initial
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD20
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e99c9e115ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mutt-language-server
+ pkgdesc = mutt/neomutt's language server
+ pkgver = 0.0.0
+ pkgrel = 1
+ url = https://github.com/Freed-Wu/mutt-language-server
+ arch = any
+ license = GPL3
+ makedepends = python-installer
+ depends = python-pygls
+ depends = python-platformdirs
+ optdepends = python-pypandoc
+ optdepends = python-markdown-it-py
+ source = https://files.pythonhosted.org/packages/py3/m/mutt_language_server/mutt_language_server-0.0.0-py3-none-any.whl
+ sha256sums = db062b5028e93aa9304d2783cd73017320587ac64fc4d8c01f514ae1015a4bf0
+
+pkgname = mutt-language-server
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8a5cafba2b8e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
+!/*.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1dde8fa1d548
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# shellcheck shell=bash disable=SC2034,SC2154
+# Maintainer: Wu Zhenyu <wuzhenyu@ustc.edu>
+# Updated by https://github.com/Freed-Wu/mutt-language-server/blob/main/.github/workflows/main.yml
+pkgname=mutt-language-server
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="mutt/neomutt's language server"
+arch=(any)
+url=https://github.com/Freed-Wu/mutt-language-server
+depends=(python-pygls python-platformdirs)
+optdepends=(python-pypandoc python-markdown-it-py)
+makedepends=(python-installer)
+license=(GPL3)
+_py=py3
+source=("https://files.pythonhosted.org/packages/$_py/${pkgname::1}/${pkgname//-/_}/${pkgname//-/_}-$pkgver-$_py-none-any.whl")
+sha256sums=('db062b5028e93aa9304d2783cd73017320587ac64fc4d8c01f514ae1015a4bf0')
+
+package() {
+ python -m installer -d "$pkgdir" ./*.whl
+}