summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2021-01-08 21:51:42 +0100
committerKr1ss2021-01-08 21:51:42 +0100
commitba43a29e3a228499b078a71f6c56d50e7b7ffb62 (patch)
tree39b51ab1a37137d6ffb82b12081437940aed7d5b
downloadaur-ba43a29e3a228499b078a71f6c56d50e7b7ffb62.tar.gz
initial upload: mutt-wizard 3.1-1
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD40
-rw-r--r--mutt-wizard.install50
3 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f28b7bc62e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = mutt-wizard
+ pkgdesc = Simple interface to auto-configure neomutt and isync with safe passwords
+ pkgver = 3.1
+ pkgrel = 1
+ url = https://github.com/lukesmithxyz/mutt-wizard
+ install = mutt-wizard.install
+ arch = any
+ license = GPL3
+ depends = neomutt
+ depends = isync
+ depends = msmtp
+ depends = notmuch-runtime
+ depends = pass
+ depends = curl
+ optdepends = imagemagick: view images inside of the neomutt TUI
+ optdepends = w3m: view HTML email and images inside of the neomutt TUI
+ optdepends = lynx: view HTML email inside of the neomutt TUI
+ optdepends = links: view HTML email inside of the neomutt TUI
+ optdepends = elinks: view HTML email inside of the neomutt TUI
+ optdepends = urlview: list URLs found in mails to open them in a browser
+ optdepends = abook: contact store and tab completion
+ optdepends = protonmail-bridge: use neomutt with protonmail accounts
+ optdepends = pam-gnupg: automatically unlock gpg keys at session login
+ optdepends = cron: set up automatic mail syncing
+ options = zipman
+ source = mutt-wizard-3.1.tgz::https://github.com/lukesmithxyz/mutt-wizard/archive/v3.1.tar.gz
+ b2sums = 699c2a43231240bae49a7280ea4b983c5025c566b109d46e27c14fad7b4d0a9359af3f32581f74426464f4e16c37dc69b75a33944237316198b79007e408077a
+
+pkgname = mutt-wizard
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..886b49563dec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer : Kr1ss $(tr +- .@ <<<'<kr1ss+x-yandex+com>')
+# Upstream author : Luke Smith <https://git{hub,lab}.com/lukesmithxyz/>
+
+
+pkgname=mutt-wizard
+pkgver=3.1
+pkgrel=1
+
+pkgdesc='Simple interface to auto-configure neomutt and isync with safe passwords'
+arch=('any')
+url="https://github.com/lukesmithxyz/$pkgname"
+license=('GPL3')
+
+depends=('neomutt' 'isync' 'msmtp' 'notmuch-runtime' 'pass' 'curl')
+optdepends=('imagemagick: view images inside of the neomutt TUI'
+ 'w3m: view HTML email and images inside of the neomutt TUI'
+ 'lynx: view HTML email inside of the neomutt TUI'
+ 'links: view HTML email inside of the neomutt TUI'
+ 'elinks: view HTML email inside of the neomutt TUI'
+ 'urlview: list URLs found in mails to open them in a browser'
+ 'abook: contact store and tab completion'
+ 'protonmail-bridge: use neomutt with protonmail accounts'
+ 'pam-gnupg: automatically unlock gpg keys at session login'
+ 'cron: set up automatic mail syncing')
+
+options=('zipman')
+
+install="$pkgname.install"
+source=("$pkgname-$pkgver.tgz::$url/archive/v$pkgver.tar.gz")
+b2sums=('699c2a43231240bae49a7280ea4b983c5025c566b109d46e27c14fad7b4d0a9359af3f32581f74426464f4e16c37dc69b75a33944237316198b79007e408077a')
+
+
+package() {
+ cd "$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" -s install
+ install -Dm644 README.md -t"$pkgdir/usr/share/doc/$pkgname/"
+}
+
+
+# vim: ts=2 sw=2 et ft=PKGBUILD:
diff --git a/mutt-wizard.install b/mutt-wizard.install
new file mode 100644
index 000000000000..6146cdaf3e61
--- /dev/null
+++ b/mutt-wizard.install
@@ -0,0 +1,50 @@
+post_upgrade() {
+ if [ $(vercmp r847 "$2") = 1 ]; then
+ printf "\e[1;32m==>\e[0;1;33m %s\e[0m\n" 'NOTE: mutt-wizard-git'
+ printf "\e[1;34m ->\e[0;1m %s\e[0m\n" 'There have been breaking changes to the "mw" CLI.'
+ printf "\e[1;34m ->\e[0;1m %s\e[0m\n" 'Please consult the README.md file and the manual mw(1).'
+ fi
+}
+
+post_install() {
+ echo -e "\n\e[1m Luke’s mutt-wizard $1\e[0m\n"
+ cat <<-END
+ Some useful hints
+ ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯
+ • Gmail accounts need to create an App Password to use with less secure applica-
+ tions. This password is single-use (i.e. for setup) and will be stored and en-
+ crypted locally. Enabling third-party applications requires turning off two-
+ factor authentication, and this will circumvent that. You might also need to
+ manually "Enable IMAP" in the settings.
+ • Protonmail accounts require a "Protonmail Bridge" to access PM's IMAP and SMTP
+ servers. Configure that before running mutt-wizard. Note that when mutt-wizard
+ asks for a password, you should put in your bridge password, not your account
+ password.
+ • Protonmail bridge is prone to timing out. Watch out for this while adding an
+ account. If the bridge times out, try again. It might help to increase the
+ timeout in your mbsyncrc.
+ • If you have a university email or enterprise-hosted email for work, there might
+ be other hurdles or two-factor authentication you have to jump through. Some,
+ for example, will want you to create a separate IMAP password, etc.
+ • isync is not fully UTF-8 compatible, so non-Latin characters may be garbled
+ (although sync should succeed). Also, mw will not auto-create mailbox shortcuts
+ since it is looking for English mailbox names. I strongly recommend you to set
+ your email language to English on your mail server to avoid these problems.
+
+ Help the project
+ ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯
+ • Try mutt-wizard out on weird machines and weird email addresses and report any
+ errors.
+ • Open a PR to add new server information into ’domains.csv’, so their users can
+ more easily use mutt-wizard.
+ • If nothing else, donate: https://paypal.me/LukeMSmith !
+
+ See Luke’s website: https://lukesmith.xyz/ - email him at: luke<at>lukesmith.xyz
+
+ --> mutt-wizard is free/libre software, licensed under the GPLv3 <--
+
+ END
+}
+
+
+# vim: ts=2 sw=2 noet ft=bash: