summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTérence Clastres2019-05-31 16:24:39 +0200
committerTérence Clastres2019-05-31 16:24:39 +0200
commit64fd2a5f20025d87399f5ebdeda62b3bc4c3d633 (patch)
tree309cc54a8602ff624f0a50185b55c73caaf3908d
parent437a7a453c5e2dd21628b608e6e0b14fe548c4f0 (diff)
downloadaur-64fd2a5f20025d87399f5ebdeda62b3bc4c3d633.tar.gz
Sync to 3.32, update commit hash, add !602 making the revert patch no longer
needed
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
-rw-r--r--revert.patch31
3 files changed, 13 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 472fe6059c1b..562a46ff9342 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mutter-781835-workaround
pkgdesc = A window manager for GNOME. This package reverts a commit which may causes performance problems for nvidia driver users. Some performance patches also included.
- pkgver = 3.32.2
- pkgrel = 4
+ pkgver = 3.32.2+5+g13a1624c1
+ pkgrel = 1
url = https://gitlab.gnome.org/GNOME/mutter
arch = x86_64
groups = gnome
@@ -30,14 +30,12 @@ pkgbase = mutter-781835-workaround
depends = gnome-shell
provides = mutter
conflicts = mutter
- source = mutter-781835-workaround::git+https://gitlab.gnome.org/GNOME/mutter.git#commit=189f71f5d1e70dd16796418d568d3e3e4cad49e0
+ source = mutter-781835-workaround::git+https://gitlab.gnome.org/GNOME/mutter.git#commit=13a1624c1050c91cd4d8a298f7a10fafe56fe9e5
source = 0001-wayland-output-Report-unscaled-size-even-in-logical-.patch
source = 216.patch
- source = revert.patch
sha256sums = SKIP
sha256sums = 842162bf8cec5d69fdb80c85fd152ddd3db6a9179d11d6f81d486f79814838c0
sha256sums = ed4f3cf738a3cffdf8a6e1a352bf24d74078c3b26fb9262c5746e0d95b9df756
- sha256sums = 2d2e305e0a6cca087bb8164f81bdc0ae7a5ca8e9c13c81d7fd5252eb3563fc09
pkgname = mutter-781835-workaround
diff --git a/PKGBUILD b/PKGBUILD
index 517535961fed..fd19747720e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,10 @@
# Patched package maintainer: Saren Arterius <saren@wtako.net>
# Patch origin: https://gist.github.com/DeadMetaler/12622bf9415c1100f2d436ffbd6778c6
-### BUILD OPTIONS
-# Set these variables to ANYTHING that is not null to enable them
-
-### Revert offending commit, recommanded to leave disable if not using NVIDIA
-_revert=
-
pkgname=mutter-781835-workaround
-pkgver=3.32.2
-pkgrel=4
+pkgver=3.32.2+5+g13a1624c1
+pkgrel=1
pkgdesc="A window manager for GNOME. This package reverts a commit which may causes performance problems for nvidia driver users. Some performance patches also included."
url="https://gitlab.gnome.org/GNOME/mutter"
arch=(x86_64)
@@ -27,15 +21,13 @@ checkdepends=(xorg-server-xvfb)
provides=(mutter)
conflicts=(mutter)
groups=(gnome)
-_commit=189f71f5d1e70dd16796418d568d3e3e4cad49e0 # tags/3.32.2^0
+_commit=13a1624c1050c91cd4d8a298f7a10fafe56fe9e5 # tags/3.32.2^5
source=("$pkgname::git+https://gitlab.gnome.org/GNOME/mutter.git#commit=$_commit"
0001-wayland-output-Report-unscaled-size-even-in-logical-.patch
- 216.patch
- revert.patch)
+ 216.patch)
sha256sums=('SKIP'
'842162bf8cec5d69fdb80c85fd152ddd3db6a9179d11d6f81d486f79814838c0'
- 'ed4f3cf738a3cffdf8a6e1a352bf24d74078c3b26fb9262c5746e0d95b9df756'
- '2d2e305e0a6cca087bb8164f81bdc0ae7a5ca8e9c13c81d7fd5252eb3563fc09')
+ 'ed4f3cf738a3cffdf8a6e1a352bf24d74078c3b26fb9262c5746e0d95b9df756')
pkgver() {
cd $pkgname
@@ -102,16 +94,15 @@ prepare() {
# backends: Do not reload keymap on new keyboard notifications
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/579
- git cherry-pick -n 8ba1e42c
+ git cherry-pick -n b01edc22
+
+ # cogl: Remove GLX "threaded swap wait" used on Nvidia [performance]
+ # https://gitlab.gnome.org/GNOME/mutter/merge_requests/602
+ git cherry-pick -n 88ee2f51
# '
# Commented multiline comment end, remove the # above if disabling the patches
- # Revert offending commit
- if [ -n "$_revert" ]; then
- patch -Np1 -i ../revert.patch
- fi
-
# https://bugzilla.mozilla.org/show_bug.cgi?id=1534089
patch -Np1 -i ../0001-wayland-output-Report-unscaled-size-even-in-logical-.patch
}
diff --git a/revert.patch b/revert.patch
deleted file mode 100644
index c37fd103a874..000000000000
--- a/revert.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/src/backends/x11/meta-backend-x11.c 2017-04-18 12:12:13.502104430 +0300
-+++ b/src/backends/x11/meta-backend-x11.c 2017-04-18 12:17:36.020693209 +0300
-@@ -605,12 +605,6 @@
- static void
- meta_backend_x11_init (MetaBackendX11 *x11)
- {
-- /* XInitThreads() is needed to use the "threaded swap wait" functionality
-- * in Cogl - see meta_renderer_x11_create_cogl_renderer(). We call it here
-- * to hopefully call it before any other use of XLib.
-- */
-- XInitThreads();
--
- /* We do X11 event retrieval ourselves */
- clutter_x11_disable_event_retrieval ();
-
---- a/src/backends/x11/meta-renderer-x11.c 2017-04-18 12:12:13.502104430 +0300
-+++ b/src/backends/x11/meta-renderer-x11.c 2017-04-18 12:20:34.369354522 +0300
-@@ -74,14 +74,6 @@
- cogl_renderer_set_custom_winsys (cogl_renderer, get_x11_cogl_winsys_vtable);
- cogl_xlib_renderer_set_foreign_display (cogl_renderer, xdisplay);
-
-- /* Set up things so that if the INTEL_swap_event extension is not present,
-- * but the driver is known to have good thread support, we use an extra
-- * thread and call glXWaitVideoSync() in the thread. This allows idles
-- * to work properly, even when Mutter is constantly redrawing new frames;
-- * otherwise, without INTEL_swap_event, we'll just block in glXSwapBuffers().
-- */
-- cogl_xlib_renderer_set_threaded_swap_wait_enabled (cogl_renderer, TRUE);
--
- return cogl_renderer;
- }