summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaren Arterius2019-04-30 20:22:11 +0800
committerSaren Arterius2019-04-30 20:22:11 +0800
commit6de1e96c8b2b756e20521ad9f7230aacefb9bdac (patch)
tree8efbd60f0e782e85eebbed14e9555b253a0bf2db
parent3fd1f3a0fb30f6d30c2d25f2dd38d2eb44e64620 (diff)
downloadaur-6de1e96c8b2b756e20521ad9f7230aacefb9bdac.tar.gz
fix build
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34d83e66e15d..617f3c9a06f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mutter-781835-workaround
pkgdesc = A window manager for GNOME. This package reverts a commit which may causes performance problems for nvidia driver users. Some performance patches also included.
- pkgver = 3.32.1+2+gabc3fdcc6
+ pkgver = 3.32.1+3+g9a795d3d0
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/mutter
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 5e0c2da72fd2..a94e45678ad8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ _revert=
pkgname=mutter-781835-workaround
-pkgver=3.32.1+2+gabc3fdcc6
+pkgver=3.32.1+3+g9a795d3d0
pkgrel=1
pkgdesc="A window manager for GNOME. This package reverts a commit which may causes performance problems for nvidia driver users. Some performance patches also included."
url="https://gitlab.gnome.org/GNOME/mutter"
@@ -55,23 +55,27 @@ prepare() {
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/189
git cherry-pick -n d774fb22
+ # Consolidate all frame throttling into clutter-stage-cogl [performance]
+ # https://gitlab.gnome.org/GNOME/mutter/merge_requests/363
+ # Conflict!
+ # h_first=$(git log --oneline --all | grep 'clutter/stage-cogl: Remove magic numbers' | tail -n 1 | awk '{print $1}') # Sorry guys
+ # h_last=$(git log --oneline --all | grep 'clutter/master-clock: Remove fallback throttles' | tail -n 1 | awk '{print $1}') # Sorry guys
+ # echo "Found $h_first^$h_last for MR363"
+ # git cherry-pick -n $h_first^..$h_last || zsh
+
# clutter-stage-cogl: Reduce output latency and reduce missed frames too [performance]
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/281
# first commit replaced by !363
- hash=$(git log --oneline --all | grep 'clutter-stage-cogl: Reschedule update on present' | head -n 1 | awk '{print $1}') # Sorry guys
- echo "Found $hash for MR281"
- git cherry-pick -n $hash
-
- # Consolidate all frame throttling into clutter-stage-cogl [performance]
- # https://gitlab.gnome.org/GNOME/mutter/merge_requests/363
- git cherry-pick -n fd8a2de8^..265772a4
+ # Conflict!
+ # hash=$(git log --oneline --all | grep 'clutter-stage-cogl: Reschedule update on present' | head -n 1 | awk '{print $1}') # Sorry guys
+ # echo "Found $hash for MR281"
+ # git cherry-pick -n $hash
# clutter: Deliver events sooner when possible
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/168
# still has issues with 1000Hz mice
# git cherry-pick -n ae8fc614
-
# Resource scale computation optimizations
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/493
git cherry-pick -n 3aa449af^..1017ce44