summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTérence Clastres2019-05-02 18:34:42 +0200
committerTérence Clastres2019-05-02 18:34:42 +0200
commit97bd2c2f98258a3c7b5fdcb8faf5f4455ef8cc02 (patch)
tree3bd27adb05a6dee07f03f2972f13e31b2ee927cc
parent8e339fb6135d98139ab77095c39948c8b0551bde (diff)
downloadaur-97bd2c2f98258a3c7b5fdcb8faf5f4455ef8cc02.tar.gz
Fix conflicts
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b34d18025c89..ddc7da32fc9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -58,19 +58,18 @@ prepare() {
# Consolidate all frame throttling into clutter-stage-cogl [performance]
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/363
- # Conflict!
- # h_first=$(git log --oneline --all | grep 'clutter/stage-cogl: Remove magic numbers' | tail -n 1 | awk '{print $1}') # Sorry guys
- # h_last=$(git log --oneline --all | grep 'clutter/master-clock: Remove fallback throttles' | tail -n 1 | awk '{print $1}') # Sorry guys
- # echo "Found $h_first^$h_last for MR363"
- # git cherry-pick -n $h_first^..$h_last || zsh
+ h_first=$(git log --oneline --all | grep "clutter/stage-cogl: Don't skip over the next frame" | tail -n 1 | awk '{print $1}') # Sorry guys
+ h_last=$(git log --oneline --all | grep 'clutter/master-clock: Remove fallback throttles' | tail -n 1 | awk '{print $1}') # Sorry guys
+ echo "Found $h_first^$h_last for MR363"
+ git cherry-pick -n $h_first^..$h_last || zsh
# clutter-stage-cogl: Reduce output latency and reduce missed frames too [performance]
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/281
# first commit replaced by !363
# Conflict!
- # hash=$(git log --oneline --all | grep 'clutter-stage-cogl: Reschedule update on present' | head -n 1 | awk '{print $1}') # Sorry guys
- # echo "Found $hash for MR281"
- # git cherry-pick -n $hash
+ hash=$(git log --oneline --all | grep 'clutter-stage-cogl: Reschedule update on present' | head -n 1 | awk '{print $1}') # Sorry guys
+ echo "Found $hash for MR281"
+ git cherry-pick -n $hash -Xtheirs
# clutter: Deliver events sooner when possible
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/168