summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaren Arterius2019-05-17 11:09:35 +0800
committerSaren Arterius2019-05-17 11:09:35 +0800
commitb3d230fef307345cef9f0d017eda7a32e14b14f8 (patch)
treee42137f29edb905b475be574429c8d4cdacc8a8e
parent8feded530565fa103c8bd86777d00177e562484b (diff)
downloadaur-b3d230fef307345cef9f0d017eda7a32e14b14f8.tar.gz
fix mr575 hash
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64aec07f7de2..0019bfcebe61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mutter-781835-workaround
pkgdesc = A window manager for GNOME. This package reverts a commit which may causes performance problems for nvidia driver users. Some performance patches also included.
pkgver = 3.32.2
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.gnome.org/GNOME/mutter
arch = x86_64
groups = gnome
diff --git a/PKGBUILD b/PKGBUILD
index 73cd972bf00b..b5dc25b4a910 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ _revert=
pkgname=mutter-781835-workaround
pkgver=3.32.2
-pkgrel=2
+pkgrel=3
pkgdesc="A window manager for GNOME. This package reverts a commit which may causes performance problems for nvidia driver users. Some performance patches also included."
url="https://gitlab.gnome.org/GNOME/mutter"
arch=(x86_64)
@@ -94,7 +94,10 @@ prepare() {
# Honour `CLUTTER_ACTOR_NO_LAYOUT` more efficiently [performance]
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/575
- git cherry-pick -n 90aeecac^..022f26d4
+ h_first=$(git log --oneline --all | grep "clutter/stage: Add an API for shallow relayouts" | tail -n 1 | awk '{print $1}') # Sorry guys
+ h_last=$(git log --oneline --all | grep 'clutter/actor: Use the new shallow relayout API' | tail -n 1 | awk '{print $1}') # Sorry guys
+ echo "Found $h_first^$h_last for MR575"
+ git cherry-pick -n $h_first^..$h_last
# WIP: backends: Do not reload keymap on new keyboard notifications
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/579