summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTérence Clastres2019-03-27 15:16:30 +0100
committerTérence Clastres2019-03-27 15:34:36 +0100
commitbb1b83f79510ae226231d0557d5679030e014f1a (patch)
treef38d9d41a58124139970ad32a7569376cd863200
parent179389767c93e0f7ea330d848295d95d6740cd26 (diff)
downloadaur-bb1b83f79510ae226231d0557d5679030e014f1a.tar.gz
Sync with [extra]
-rw-r--r--.SRCINFO6
-rw-r--r--0001-wayland-xdg-shell-Correct-window-menu-position-in-lo.patch42
-rw-r--r--PKGBUILD13
3 files changed, 55 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fba6b63ddb9c..ca4623815167 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mutter-781835-workaround
pkgdesc = A window manager for GNOME. This package reverts a commit which may causes performance problems for nvidia driver users. Some performance patches also included.
- pkgver = 3.32.0+41+gf0b9654de
+ pkgver = 3.32.0+42+g58f7059ea
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/mutter
arch = x86_64
@@ -30,10 +30,12 @@ pkgbase = mutter-781835-workaround
depends = gnome-shell
provides = mutter
conflicts = mutter
- source = mutter-781835-workaround::git+https://gitlab.gnome.org/GNOME/mutter.git#commit=f0b9654deb947e49e42b76d6daa42b86e5b0ec17
+ source = mutter-781835-workaround::git+https://gitlab.gnome.org/GNOME/mutter.git#commit=58f7059ea42c04fbb28c7210a287437f0f55b2d8
+ source = 0001-wayland-xdg-shell-Correct-window-menu-position-in-lo.patch
source = 216.patch
source = revert.patch
sha256sums = SKIP
+ sha256sums = 8628fe45738d631d7776204be76cc091c5a1359d2874945c7913c7705330f816
sha256sums = ed4f3cf738a3cffdf8a6e1a352bf24d74078c3b26fb9262c5746e0d95b9df756
sha256sums = 2d2e305e0a6cca087bb8164f81bdc0ae7a5ca8e9c13c81d7fd5252eb3563fc09
diff --git a/0001-wayland-xdg-shell-Correct-window-menu-position-in-lo.patch b/0001-wayland-xdg-shell-Correct-window-menu-position-in-lo.patch
new file mode 100644
index 000000000000..47390ba3a7fb
--- /dev/null
+++ b/0001-wayland-xdg-shell-Correct-window-menu-position-in-lo.patch
@@ -0,0 +1,42 @@
+From da01a3eaffe01ae2c3ea826171057548c7973c39 Mon Sep 17 00:00:00 2001
+Message-Id: <da01a3eaffe01ae2c3ea826171057548c7973c39.1553635567.git.jan.steffens@gmail.com>
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Tue, 26 Mar 2019 22:24:44 +0100
+Subject: [PATCH] wayland/xdg-shell: Correct window menu position in logical
+ layout mode
+
+Fixes https://gitlab.gnome.org/GNOME/mutter/issues/527
+---
+ src/wayland/meta-wayland-legacy-xdg-shell.c | 2 +-
+ src/wayland/meta-wayland-xdg-shell.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/wayland/meta-wayland-legacy-xdg-shell.c b/src/wayland/meta-wayland-legacy-xdg-shell.c
+index 1523481d4..823064177 100644
+--- a/src/wayland/meta-wayland-legacy-xdg-shell.c
++++ b/src/wayland/meta-wayland-legacy-xdg-shell.c
+@@ -258,7 +258,7 @@ zxdg_toplevel_v6_show_window_menu (struct wl_client *client,
+ if (!meta_wayland_seat_get_grab_info (seat, surface, serial, FALSE, NULL, NULL))
+ return;
+
+- monitor_scale = window->monitor->scale;
++ monitor_scale = meta_window_wayland_get_geometry_scale (window);
+ meta_window_show_menu (window, META_WINDOW_MENU_WM,
+ window->buffer_rect.x + (x * monitor_scale),
+ window->buffer_rect.y + (y * monitor_scale));
+diff --git a/src/wayland/meta-wayland-xdg-shell.c b/src/wayland/meta-wayland-xdg-shell.c
+index d747f5c07..fa0207a03 100644
+--- a/src/wayland/meta-wayland-xdg-shell.c
++++ b/src/wayland/meta-wayland-xdg-shell.c
+@@ -264,7 +264,7 @@ xdg_toplevel_show_window_menu (struct wl_client *client,
+ if (!meta_wayland_seat_get_grab_info (seat, surface, serial, FALSE, NULL, NULL))
+ return;
+
+- monitor_scale = window->monitor->scale;
++ monitor_scale = meta_window_wayland_get_geometry_scale (window);
+ meta_window_show_menu (window, META_WINDOW_MENU_WM,
+ window->buffer_rect.x + (x * monitor_scale),
+ window->buffer_rect.y + (y * monitor_scale));
+--
+2.21.0
+
diff --git a/PKGBUILD b/PKGBUILD
index ec5a8fbd71da..c916afc61208 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ _revert=0
pkgname=mutter-781835-workaround
-pkgver=3.32.0+41+gf0b9654de
+pkgver=3.32.0+42+g58f7059ea
pkgrel=1
pkgdesc="A window manager for GNOME. This package reverts a commit which may causes performance problems for nvidia driver users. Some performance patches also included."
url="https://gitlab.gnome.org/GNOME/mutter"
@@ -27,19 +27,21 @@ checkdepends=(xorg-server-xvfb)
provides=(mutter)
conflicts=(mutter)
groups=(gnome)
-_commit=f0b9654deb947e49e42b76d6daa42b86e5b0ec17 # master
+_commit=58f7059ea42c04fbb28c7210a287437f0f55b2d8 # master
source=("$pkgname::git+https://gitlab.gnome.org/GNOME/mutter.git#commit=$_commit"
+ 0001-wayland-xdg-shell-Correct-window-menu-position-in-lo.patch
216.patch
revert.patch)
sha256sums=('SKIP'
+ '8628fe45738d631d7776204be76cc091c5a1359d2874945c7913c7705330f816'
'ed4f3cf738a3cffdf8a6e1a352bf24d74078c3b26fb9262c5746e0d95b9df756'
'2d2e305e0a6cca087bb8164f81bdc0ae7a5ca8e9c13c81d7fd5252eb3563fc09')
pkgver() {
cd $pkgname
- _manual_bump=41 # horrible temporary workaround to account new versioning
- git describe --tags | sed "s/-/+/g;s/25/$_manual_bump/"
+ _manual_bump=42 # horrible temporary workaround to account new versioning
+ git describe --tags | sed "s/-/+/g;s/33/$_manual_bump/"
}
prepare() {
@@ -100,6 +102,9 @@ prepare() {
patch -Np1 -i ../revert.patch
fi
+ # https://gitlab.gnome.org/GNOME/mutter/issues/527
+ patch -Np1 -i ../0001-wayland-xdg-shell-Correct-window-menu-position-in-lo.patch
+
# cogl-winsys-glx: Fix frame notification race/leak [performance]
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/216
git apply -3 ../216.patch