summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNorbert Pfeiler2015-06-19 18:22:32 +0200
committerNorbert Pfeiler2015-06-19 18:22:32 +0200
commitf6268e594af50796934bdc45b05968ae4c24c31b (patch)
tree146ad807c394ff68c4903c754acb9039c56e9ca3
downloadaur-f6268e594af50796934bdc45b05968ae4c24c31b.tar.gz
initial commit
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD63
-rw-r--r--catalyst-comment.patch16
-rw-r--r--mutter-catalyst.install19
5 files changed, 140 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a234195eb97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = mutter-catalyst
+ pkgdesc = A window manager for GNOME with patch for catalyst compatibility
+ pkgver = 3.16.2
+ pkgrel = 1
+ url = http://www.gnome.org
+ install = mutter-catalyst.install
+ arch = i686
+ arch = x86_64
+ groups = gnome
+ license = GPL
+ makedepends = intltool
+ makedepends = gnome-doc-utils
+ makedepends = libxkbcommon-x11
+ depends = clutter
+ depends = dconf
+ depends = gobject-introspection
+ depends = gsettings-desktop-schemas
+ depends = libcanberra
+ depends = startup-notification
+ depends = zenity
+ depends = libsm
+ depends = gnome-desktop
+ depends = upower
+ depends = libxkbcommon-x11
+ provides = mutter=3.16.2
+ conflicts = mutter-wayland
+ conflicts = mutter
+ replaces = mutter-wayland
+ options = !emptydirs
+ source = http://ftp.gnome.org/pub/gnome/sources/mutter/3.16/mutter-3.16.2.tar.xz
+ source = catalyst-comment.patch
+ sha256sums = 4a2b752f0b3aa59f50563190222623324f5154acbb6bf174213f5849e77d0763
+ sha256sums = fe058744aadcf87cb92a9268beddbb1a501631e02b335a58c593b36c8b47d7d9
+
+pkgname = mutter-catalyst
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c6abb4782e71
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+# makepkg folders
+src
+pkg
+
+# source archives and generated packages
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5aaf35293f0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Norbert Pfeiler <norbert.pfeiler ät gmail.com>
+# Contributor: Christian Assfalg <ch.assfalg_at_gmx_dot_de>
+# Also Maintainers and Contributors of the ›mutter‹ package, this package is based on
+
+pkgname=mutter-catalyst
+pkgver=3.16.2
+pkgrel=1
+pkgdesc="A window manager for GNOME with patch for catalyst compatibility"
+arch=(i686 x86_64)
+license=('GPL')
+depends=('clutter'
+ 'dconf'
+ 'gobject-introspection'
+ 'gsettings-desktop-schemas'
+ 'libcanberra'
+ 'startup-notification'
+ 'zenity'
+ 'libsm'
+ 'gnome-desktop'
+ 'upower'
+ 'libxkbcommon-x11'
+)
+makedepends=('intltool'
+ 'gnome-doc-utils'
+ 'libxkbcommon-x11'
+)
+conflicts=('mutter-wayland'
+ 'mutter'
+)
+replaces=('mutter-wayland')
+provides=("mutter=${pkgver}")
+url='http://www.gnome.org'
+groups=('gnome')
+options=('!emptydirs')
+install=mutter-catalyst.install
+source=("http://ftp.gnome.org/pub/gnome/sources/mutter/${pkgver:0:4}/mutter-$pkgver.tar.xz"
+ 'catalyst-comment.patch' )
+sha256sums=('4a2b752f0b3aa59f50563190222623324f5154acbb6bf174213f5849e77d0763'
+ 'fe058744aadcf87cb92a9268beddbb1a501631e02b335a58c593b36c8b47d7d9')
+
+build() {
+ cd "mutter-$pkgver"
+
+ #https://bugzilla.gnome.org/show_bug.cgi?id=741581
+ echo "Commenting out call to function with XRRChangeOutputProperty to fix issue with catalyst"
+ patch -p1 < ../catalyst-comment.patch
+ echo "Patch applied"
+
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --libexecdir=/usr/lib/mutter \
+ --localstatedir=/var --disable-static \
+ --disable-schemas-compile --enable-compile-warnings=minimum
+
+ #https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+package() {
+ cd "mutter-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/catalyst-comment.patch b/catalyst-comment.patch
new file mode 100644
index 000000000000..aef3a9a42a24
--- /dev/null
+++ b/catalyst-comment.patch
@@ -0,0 +1,16 @@
+--- mutter-3.14.3/src/backends/x11/meta-monitor-manager-xrandr.c 2014-11-12 18:27:07.000000000 +0100
++++ mutter-3.14.3/src/backends/x11/meta-monitor-manager-xrandr.c 2014-12-17 18:11:05.906206113 +0100
+@@ -933,11 +933,11 @@
+ DefaultRootWindow (manager_xrandr->xdisplay),
+ (XID)output_info->output->winsys_id);
+ }
+-
++/*
+ output_set_presentation_xrandr (manager_xrandr,
+ output_info->output,
+ output_info->is_presentation);
+-
++*/
+ output->is_primary = output_info->is_primary;
+ output->is_presentation = output_info->is_presentation;
+ }
diff --git a/mutter-catalyst.install b/mutter-catalyst.install
new file mode 100644
index 000000000000..30d1544bdabf
--- /dev/null
+++ b/mutter-catalyst.install
@@ -0,0 +1,19 @@
+pkgname=mutter-catalyst
+
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+}
+
+pre_upgrade() {
+ if [ -f /usr/share/gconf/schemas/$pkgname.schemas ]; then
+ /usr/sbin/gconfpkg --uninstall $pkgname
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}